From 6d51a4091c39ba489a9d2c2e73e4729adb1385ce Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Sat, 25 Aug 2018 22:10:28 -0700
Subject: [PATCH] libartnet: Fix compile with GCC7

error: memset' used with length equal to number of elements without
multiplication by element size

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 libs/libartnet/Makefile               |  2 +-
 libs/libartnet/patches/002-gcc7.patch | 13 +++++++++++++
 2 files changed, 14 insertions(+), 1 deletion(-)
 create mode 100644 libs/libartnet/patches/002-gcc7.patch

diff --git a/libs/libartnet/Makefile b/libs/libartnet/Makefile
index c3a57d568..5e7fc3c88 100644
--- a/libs/libartnet/Makefile
+++ b/libs/libartnet/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libartnet
 PKG_VERSION:=1.1.2
-PKG_RELEASE:=1.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/OpenLightingProject/libartnet/releases/download/1.1.2
diff --git a/libs/libartnet/patches/002-gcc7.patch b/libs/libartnet/patches/002-gcc7.patch
new file mode 100644
index 000000000..44dde9069
--- /dev/null
+++ b/libs/libartnet/patches/002-gcc7.patch
@@ -0,0 +1,13 @@
+diff --git a/artnet/transmit.c b/artnet/transmit.c
+index ce19b11..e882db9 100644
+--- a/artnet/transmit.c
++++ b/artnet/transmit.c
+@@ -163,7 +163,7 @@ int artnet_tx_tod_data(node n, int id) {
+   bloc = 0;
+ 
+   while (remaining > 0) {
+-    memset(&tod.data.toddata.tod,0x00, ARTNET_MAX_UID_COUNT);
++    memset(&tod.data.toddata.tod,0x00, ARTNET_MAX_UID_COUNT * sizeof(tod.data.toddata.tod));
+     lim = min(ARTNET_MAX_UID_COUNT, remaining);
+     tod.data.toddata.blockCount = bloc++;
+     tod.data.toddata.uidCount = lim;