gnunet: update to version 0.17.5
Beware that switching to the new major version 0.17.x results in incompatibility with clients still running 0.16.x. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
d3b5074476
commit
6d49ad9e5c
3 changed files with 8 additions and 46 deletions
|
@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gnunet
|
||||
|
||||
PKG_VERSION:=0.16.2
|
||||
PKG_VERSION:=0.17.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gnunet
|
||||
PKG_HASH:=b5858833836509b71d5c0d9bdc11fd1beeeaba5a75be4bbd93581a4d13e0f49a
|
||||
PKG_HASH:=8a744ff7a95d1e83215cce118050640f6c12261abe4c60a56bcf88e500f0023d
|
||||
|
||||
PKG_LICENSE:=AGPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -214,13 +214,13 @@ PLUGIN_conversation:=gnsrecord_conversation
|
|||
LIBEXEC_conversation:=helper-audio-playback helper-audio-record service-conversation
|
||||
CONF_conversation:=conversation
|
||||
|
||||
BIN_dht-cli:=dht-get dht-put dht-monitor
|
||||
BIN_dht-cli:=dht-get dht-hello dht-put dht-monitor
|
||||
PLUGIN_dht-cli:=block_test
|
||||
|
||||
DEPENDS_curl:=+libgnurl +jansson
|
||||
LIB_curl:=curl
|
||||
|
||||
DEPENDS_hostlist:=+libmicrohttpd-ssl +gnunet-curl +ca-certificates
|
||||
DEPENDS_hostlist:=+libmicrohttpd-ssl +gnunet-curl +ca-bundle
|
||||
LIBEXEC_hostlist:=daemon-hostlist
|
||||
CONF_hostlist:=hostlist
|
||||
|
||||
|
@ -232,7 +232,7 @@ PLUGIN_transport-bluetooth:=transport_bluetooth
|
|||
LIBEXEC_transport-bluetooth:=helper-transport-bluetooth
|
||||
FILE_MODES_transport-bluetooth:=/usr/lib/gnunet/libexec/gnunet-helper-transport-bluetooth:root:gnunet:4750
|
||||
|
||||
DEPENDS_transport-http_client:=+gnunet-curl +ca-certificates
|
||||
DEPENDS_transport-http_client:=+gnunet-curl +ca-bundle
|
||||
PLUGIN_transport-http_client:=transport_http_client transport_https_client
|
||||
|
||||
DEPENDS_transport-http_server:=+libmicrohttpd-ssl
|
||||
|
@ -288,7 +288,7 @@ PLUGIN_messenger:=gnsrecord_messenger
|
|||
|
||||
DEPENDS_reclaim:=+gnunet-gns +gnunet-sqlite +libpbc +libgabe +jansson
|
||||
BIN_reclaim:=did reclaim
|
||||
LIB_reclaim:=consensus abe reclaim reclaimattribute secretsharing
|
||||
LIB_reclaim:=abe consensus did reclaim reclaimattribute secretsharing
|
||||
LIBEXEC_reclaim:=service-consensus service-reclaim service-secretsharing
|
||||
CONF_reclaim:=consensus reclaim secretsharing
|
||||
PLUGIN_reclaim:=block_consensus gnsrecord_reclaim reclaim_credential_jwt reclaim_attribute_basic
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/include/gnunet_common.h
|
||||
+++ b/src/include/gnunet_common.h
|
||||
@@ -150,7 +150,6 @@ enum GNUNET_GenericReturnValue
|
||||
@@ -154,7 +154,6 @@ enum GNUNET_GenericReturnValue
|
||||
* Endian operations
|
||||
*/
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
|||
#ifdef HAVE_BYTESWAP_H
|
||||
#define BYTE_SWAP_16(x) bswap_16 (x)
|
||||
#define BYTE_SWAP_32(x) bswap_32 (x)
|
||||
@@ -170,6 +169,7 @@ enum GNUNET_GenericReturnValue
|
||||
@@ -174,6 +173,7 @@ enum GNUNET_GenericReturnValue
|
||||
56))
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -981,33 +981,13 @@ AC_ARG_WITH([mysql],
|
||||
AC_CHECK_LIB([mysqlclient], [mysql_init],
|
||||
[AC_CHECK_HEADERS([mysql/mysql.h],
|
||||
[MYSQL_LDFLAGS="-L$MYSQL_LIBDIR"
|
||||
- mysql=true],
|
||||
+ mysql=true
|
||||
+ mysql8=true],
|
||||
[mysql=false])],
|
||||
[mysql=false])])
|
||||
AC_SUBST(MYSQL_LDFLAGS)
|
||||
AC_SUBST(MYSQL_CPPFLAGS)
|
||||
|
||||
-# additional version checks for mysql
|
||||
-AS_IF([test "x$mysql" = "xtrue"],
|
||||
- [AC_MSG_CHECKING([for mysql version])
|
||||
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
|
||||
- [[include <mysql/mysql_version.h>]],
|
||||
- [[#if (MYSQL_VERSION_ID < 40100)
|
||||
-#error required at least version 4.1
|
||||
-#endif]])],
|
||||
- [mysql=true],
|
||||
- [mysql=false])
|
||||
- AS_IF([test "x$mysql" = "xfalse"],
|
||||
- [AC_MSG_RESULT([< 4.1])
|
||||
- AC_MSG_RESULT([mysql version >= 4.1 required. Will not use MySQL])])
|
||||
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
|
||||
- [[#include <mysql/mysql_version.h>]],
|
||||
- [[#if (MYSQL_VERSION_ID < 80000)
|
||||
-#error needs at least version 8.0
|
||||
-#endif]])],
|
||||
- [mysql8=true],
|
||||
- [mysql8=false])])
|
||||
-
|
||||
AS_IF([test "x$mysql" = "xtrue"],
|
||||
[AS_IF([test "x$mysql8" = "xfalse"],
|
||||
[AC_MSG_RESULT([between 4.1 and 8.0])],
|
Loading…
Reference in a new issue