cyrus-sasl: update to 2.1.28
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
eadab32450
commit
6ca60a8e6d
2 changed files with 3 additions and 26 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cyrus-sasl
|
||||
PKG_VERSION:=2.1.27
|
||||
PKG_VERSION:=2.1.28
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.cyrusimap.org/releases/
|
||||
PKG_HASH:=26866b1549b00ffd020f188a43c258017fa1c382b3ddadd8201536f72efb05d5
|
||||
PKG_SOURCE_URL:=https://github.com/cyrusimap/cyrus-sasl/releases/download/cyrus-sasl-2.1.28/
|
||||
PKG_HASH:=7ccfc6abd01ed67c1a0924b353e526f1b766b21f42d4562ee635a8ebfc5bb38c
|
||||
|
||||
PKG_LICENSE:=BSD-4c BSD
|
||||
PKG_LICENSE_FILES:=COPYING cmulocal/COPYING saslauthd/COPYING
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
From dcc9f51cbd4ed622cfb0f9b1c141eb2ffe3b12f1 Mon Sep 17 00:00:00 2001
|
||||
From: Quanah Gibson-Mount <quanah@symas.com>
|
||||
Date: Tue, 18 Feb 2020 19:05:12 +0000
|
||||
Subject: [PATCH] Fix #587
|
||||
|
||||
Off by one error in common.c, CVE-2019-19906.
|
||||
|
||||
Thanks to Stephan Zeisberg for reporting
|
||||
---
|
||||
lib/common.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/lib/common.c
|
||||
+++ b/lib/common.c
|
||||
@@ -190,7 +190,7 @@ int _sasl_add_string(char **out, size_t
|
||||
|
||||
if (add==NULL) add = "(null)";
|
||||
|
||||
- addlen=strlen(add); /* only compute once */
|
||||
+ addlen=strlen(add)+1; /* only compute once */
|
||||
if (_buf_alloc(out, alloclen, (*outlen)+addlen)!=SASL_OK)
|
||||
return SASL_NOMEM;
|
||||
|
Loading…
Reference in a new issue