irssi: update to 1.4.4
update to 1.4.4 switch to meson remove obsolete patch Signed-off-by: Fabian Lipken <dynasticorpheus@gmail.com>
This commit is contained in:
parent
73c053c00f
commit
6c8d81e603
2 changed files with 10 additions and 33 deletions
|
@ -8,23 +8,22 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=irssi
|
||||
PKG_VERSION:=1.2.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.4.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/irssi/irssi/releases/download/$(PKG_VERSION)/
|
||||
PKG_HASH:=a647bfefed14d2221fa77b6edac594934dc672c4a560417b1abcbbc6b88d769f
|
||||
PKG_HASH:=fefe9ec8c7b1475449945c934a2360ab12693454892be47a6d288c63eb107ead
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:irssi:irssi
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/irssi
|
||||
SUBMENU:=Instant Messaging
|
||||
|
@ -42,12 +41,12 @@ endef
|
|||
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-glibtest \
|
||||
--with-textui \
|
||||
--without-bot \
|
||||
--without-perl \
|
||||
--without-proxy
|
||||
MESON_ARGS += \
|
||||
-Dwithout-textui=no \
|
||||
-Dwith-bot=no \
|
||||
-Dwith-otr=no \
|
||||
-Dwith-perl=no \
|
||||
-Dwith-proxy=no \
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/irssi
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
From cff1385b398b59c74c535d6c0cd9deec561101fd Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Fri, 15 Feb 2019 15:02:34 -0800
|
||||
Subject: [PATCH] Fix finding OpenSSL when 1.1 with deprecated APIs disabled
|
||||
|
||||
SSL_library_init is a deprecated function. OPENSSL_init_ssl is not in 1.0.2.
|
||||
SSL_CTX_new is in both.
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -328,7 +328,7 @@ PKG_CHECK_MODULES([OPENSSL], [openssl],
|
||||
CFLAGS="$CFLAGS $OPENSSL_CFLAGS"
|
||||
LIBS="$LIBS $OPENSSL_LIBS"
|
||||
], [
|
||||
- AC_CHECK_LIB([ssl], [SSL_library_init], [
|
||||
+ AC_CHECK_LIB([ssl], [SSL_CTX_new], [
|
||||
LIBS="$LIBS -lssl -lcrypto"
|
||||
], [
|
||||
AC_MSG_ERROR([The OpenSSL library was not found])
|
Loading…
Reference in a new issue