Merge pull request #2338 from thess/alsa-test
alsa: Update to 1.1.0, disable basic audio test (bat) utility
This commit is contained in:
commit
69f2c22384
4 changed files with 14 additions and 44 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
# Copyright (C) 2006-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=alsa-lib
|
||||
PKG_VERSION:=1.0.29
|
||||
PKG_VERSION:=1.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
|
||||
http://alsa.cybermirror.org/lib/
|
||||
PKG_MD5SUM:=de67e0eca72474d6b1121037dafe1024
|
||||
PKG_MD5SUM:=69515ca73c3c4a212ef45160dea846c1
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Peter Wagner <tripolar@gmx.at>
|
||||
|
||||
|
@ -43,15 +43,12 @@ endef
|
|||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
CONFIGURE_ARGS+= \
|
||||
--disable-python \
|
||||
--disable-debug \
|
||||
--without-debug \
|
||||
$(SOFT_FLOAT_CONFIG_OPTION) \
|
||||
--with-versioned=no \
|
||||
)
|
||||
endef
|
||||
--with-versioned=no
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -27,20 +27,6 @@ AC_PREFIX_DEFAULT(/usr)
|
||||
|
||||
dnl Checks for programs.
|
||||
|
||||
-dnl try to gues cross-compiler if not set
|
||||
-if test "x$host" != "x$build" -a -z "`echo $CC | grep -e '-gcc'`";
|
||||
-then
|
||||
- AC_MSG_CHECKING(for cross-compiler)
|
||||
-
|
||||
- which ${program_prefix}gcc >/dev/null 2>&1 && CC=${program_prefix}gcc
|
||||
- which ${host_cpu}-${host_os}-gcc >/dev/null 2>&1 \
|
||||
- && CC=${host_cpu}-${host_os}-gcc
|
||||
- which ${host_cpu}-${host_vendor}-${host_os}-gcc >/dev/null 2>&1 \
|
||||
- && CC=${host_cpu}-${host_vendor}-${host_os}-gcc
|
||||
-
|
||||
- AC_MSG_RESULT($CC)
|
||||
-fi
|
||||
-
|
||||
CFLAGS="$CFLAGS -D_GNU_SOURCE"
|
||||
|
||||
|
|
@ -82,9 +82,9 @@
|
|||
#include <ctype.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/shm.h>
|
||||
#include <sys/mman.h>
|
||||
#include <limits.h>
|
||||
#include "pcm_local.h"
|
||||
--- a/src/pcm/pcm_direct.c
|
||||
+++ b/src/pcm/pcm_direct.c
|
||||
@@ -30,7 +30,7 @@
|
||||
|
@ -115,9 +115,9 @@
|
|||
#include <sys/socket.h>
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/shm.h>
|
||||
#include <pthread.h>
|
||||
#include "pcm_local.h"
|
||||
|
||||
--- a/src/pcm/pcm_shm.c
|
||||
+++ b/src/pcm/pcm_shm.c
|
||||
@@ -36,7 +36,7 @@
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
# Copyright (C) 2006-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=alsa-utils
|
||||
PKG_VERSION:=1.0.29
|
||||
PKG_VERSION:=1.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
|
||||
http://alsa.cybermirror.org/utils/
|
||||
PKG_MD5SUM:=6b289bf874c4c9a63f4b3973093dd404
|
||||
PKG_MD5SUM:=b9d6102fbbd0b68040bb77023ed30c0c
|
||||
PKG_INSTALL:=1
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
|
||||
|
@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
define Package/alsa-utils
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+alsa-lib +libncurses +libpthread
|
||||
DEPENDS:=+alsa-lib +libncursesw +libpthread
|
||||
TITLE:=ALSA (Advanced Linux Sound Architecture) utilities
|
||||
URL:=http://www.alsa-project.org/
|
||||
endef
|
||||
|
@ -44,16 +44,12 @@ define Package/alsa-utils-tests
|
|||
DEPENDS:=+alsa-lib +libpthread
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
CONFIGURE_ARGS+= \
|
||||
--disable-rpath \
|
||||
--disable-alsatest \
|
||||
--disable-bat \
|
||||
--disable-xmlto \
|
||||
, \
|
||||
ac_cv_prog_ncurses5_config=no \
|
||||
ac_cv_prog_ncursesw5_config=no \
|
||||
)
|
||||
endef
|
||||
--with-curses=ncursesw
|
||||
|
||||
define Package/alsa-utils/install
|
||||
$(INSTALL_DIR) $(1)/usr/{s,}bin
|
||||
|
|
Loading…
Reference in a new issue