libb64: add package
Add generic base64 encode/decode (static) library. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
0b37036e5a
commit
6993b5d945
2 changed files with 45 additions and 0 deletions
34
libs/libb64/Makefile
Normal file
34
libs/libb64/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=libb64
|
||||||
|
PKG_VERSION:=2.0.0
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=https://codeload.github.com/libb64/libb64/tar.gz/v$(PKG_VERSION)?
|
||||||
|
PKG_HASH:=28c43c47674409fc50e7145d4c2d26dc1f3d200889c41205e7812c2b67f26382
|
||||||
|
|
||||||
|
PKG_LICENSE:=PublicDomain
|
||||||
|
PKG_LICENSE_FILES:=LICENSE.md
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
MAKE_FLAGS+=all_src
|
||||||
|
|
||||||
|
define Package/libb64
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE:=Base64 Encoding/Decoding Routines
|
||||||
|
URL:=https://github.com/libb64/libb64
|
||||||
|
BUILDONLY:=1
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/include/b64 $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/include/b64/*.h $(1)/usr/include/b64
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,libb64))
|
11
libs/libb64/patches/100-no-Werror.patch
Normal file
11
libs/libb64/patches/100-no-Werror.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/src/Makefile
|
||||||
|
+++ b/src/Makefile
|
||||||
|
@@ -15,7 +15,7 @@ TARGETS = $(LIBRARIES)
|
||||||
|
|
||||||
|
LINK.o = gcc
|
||||||
|
|
||||||
|
-CFLAGS += -Werror -pedantic
|
||||||
|
+CFLAGS += -pedantic
|
||||||
|
CFLAGS += -I../include
|
||||||
|
|
||||||
|
vpath %.h ../include/b64
|
Loading…
Reference in a new issue