commit
6953123f1d
2 changed files with 33 additions and 47 deletions
|
@ -8,27 +8,24 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libxslt
|
PKG_NAME:=libxslt
|
||||||
PKG_VERSION:=1.1.34
|
PKG_VERSION:=1.1.37
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:=@GNOME/libxslt/$(basename $(PKG_VERSION))
|
||||||
http://xmlsoft.org/sources/ \
|
PKG_HASH:=3a4b27dc8027ccd6146725950336f1ec520928f320f144eb5fa7990ae6123ab4
|
||||||
ftp://fr.rpmfind.net/pub/libxml/
|
|
||||||
PKG_HASH:=98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f
|
|
||||||
|
|
||||||
PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
|
PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:xmlsoft:libxslt
|
PKG_CPE_ID:=cpe:/a:xmlsoft:libxslt
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
HOST_BUILD_DEPENDS:=libxml2/host
|
HOST_BUILD_DEPENDS:=libxml2/host
|
||||||
|
CMAKE_BINARY_SUBDIR:=openwrt-build
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
||||||
define Package/libxslt
|
define Package/libxslt
|
||||||
|
@ -67,36 +64,40 @@ define Package/xsltproc/description
|
||||||
XSLT XML transformation utility.
|
XSLT XML transformation utility.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CMAKE_HOST_OPTIONS += \
|
||||||
--enable-shared \
|
-DBUILD_SHARED_LIBS=OFF \
|
||||||
--enable-static \
|
-DLIBXSLT_WITH_DEBUGGER=OFF \
|
||||||
--without-python \
|
-DLIBXSLT_WITH_CRYPTO=OFF \
|
||||||
--without-crypto \
|
-DLIBXSLT_WITH_MEM_DEBUG=OFF \
|
||||||
--without-debug \
|
-DLIBXSLT_WITH_MODULES=OFF \
|
||||||
--without-mem-debug \
|
-DLIBXSLT_WITH_PROFILER=OFF \
|
||||||
--without-debugger \
|
-DLIBXSLT_WITH_PYTHON=OFF \
|
||||||
--without-plugins
|
-DLIBXSLT_WITH_TESTS=OFF \
|
||||||
|
-DLIBXSLT_WITH_THREADS=ON \
|
||||||
|
-DLIBXSLT_WITH_XSLT_DEBUG=OFF
|
||||||
|
|
||||||
HOST_CONFIGURE_ARGS += \
|
CMAKE_OPTIONS += \
|
||||||
--with-libxml-prefix=$(STAGING_DIR_HOSTPKG) \
|
-DBUILD_SHARED_LIBS=ON \
|
||||||
--without-python \
|
-DLIBXSLT_WITH_DEBUGGER=OFF \
|
||||||
--without-crypto \
|
-DLIBXSLT_WITH_CRYPTO=OFF \
|
||||||
--without-debug \
|
-DLIBXSLT_WITH_MEM_DEBUG=OFF \
|
||||||
--without-mem-debug \
|
-DLIBXSLT_WITH_MODULES=OFF \
|
||||||
--without-debugger \
|
-DLIBXSLT_WITH_PROFILER=ON \
|
||||||
--without-profiler \
|
-DLIBXSLT_WITH_PYTHON=OFF \
|
||||||
--without-plugins
|
-DLIBXSLT_WITH_TESTS=OFF \
|
||||||
|
-DLIBXSLT_WITH_THREADS=ON \
|
||||||
|
-DLIBXSLT_WITH_XSLT_DEBUG=OFF
|
||||||
|
|
||||||
define Build/InstallDev/Xslt
|
define Build/InstallDev/Xslt
|
||||||
$(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
|
$(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
|
||||||
$(1)/usr/include/libexslt $(1)/usr/lib \
|
$(1)/usr/include/libexslt $(1)/usr/lib \
|
||||||
$(1)/usr/lib/pkgconfig $(2)/share/aclocal
|
$(1)/usr/lib/pkgconfig
|
||||||
|
|
||||||
$(INSTALL_BIN) \
|
$(INSTALL_BIN) \
|
||||||
$(PKG_INSTALL_DIR)/usr/bin/xslt-config \
|
$(PKG_INSTALL_DIR)/usr/bin/xslt-config \
|
||||||
$(2)/bin/
|
$(2)/bin/
|
||||||
|
|
||||||
ln -sf $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
|
$(LN) $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
|
||||||
|
|
||||||
$(SED) \
|
$(SED) \
|
||||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
||||||
|
@ -107,16 +108,12 @@ define Build/InstallDev/Xslt
|
||||||
$(1)/usr/include/libxslt/
|
$(1)/usr/include/libxslt/
|
||||||
|
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/libxslt.{la,a,so*} \
|
$(PKG_INSTALL_DIR)/usr/lib/libxslt.so* \
|
||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
|
|
||||||
$(INSTALL_DATA) \
|
$(INSTALL_DATA) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc \
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc \
|
||||||
$(1)/usr/lib/pkgconfig/
|
$(1)/usr/lib/pkgconfig/
|
||||||
|
|
||||||
$(INSTALL_DATA) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/share/aclocal/* \
|
|
||||||
$(2)/share/aclocal
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/InstallDev/Exslt
|
define Build/InstallDev/Exslt
|
||||||
|
@ -126,7 +123,7 @@ define Build/InstallDev/Exslt
|
||||||
$(1)/usr/include/libexslt/
|
$(1)/usr/include/libexslt/
|
||||||
|
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/libexslt.{la,a,so*} \
|
$(PKG_INSTALL_DIR)/usr/lib/libexslt.so* \
|
||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
|
|
||||||
$(INSTALL_DATA) \
|
$(INSTALL_DATA) \
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -546,7 +546,7 @@ dnl make sure xml2-config is executable,
|
|
||||||
dnl test version and init our variables
|
|
||||||
dnl
|
|
||||||
|
|
||||||
-if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs print > /dev/null 2>&1
|
|
||||||
+if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs > /dev/null 2>&1
|
|
||||||
then
|
|
||||||
AC_MSG_CHECKING(for libxml libraries >= $LIBXML_REQUIRED_VERSION)
|
|
||||||
XMLVERS=`$XML_CONFIG --version`
|
|
Loading…
Reference in a new issue