Merge pull request #4108 from lucize/postsqlite
postfix: Add SQLite support and fix musl compile without POSTFIX_TLS
This commit is contained in:
commit
694e5a677c
2 changed files with 22 additions and 2 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=postfix
|
PKG_NAME:=postfix
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.porcupine.org/mirrors/postfix-release/official/
|
PKG_SOURCE_URL:=ftp://ftp.porcupine.org/mirrors/postfix-release/official/
|
||||||
PKG_VERSION:=3.1.4
|
PKG_VERSION:=3.1.4
|
||||||
PKG_MD5SUM:=878a059d92ee3b093d7d3e97248c915d
|
PKG_MD5SUM:=878a059d92ee3b093d7d3e97248c915d
|
||||||
|
@ -25,7 +25,7 @@ define Package/postfix
|
||||||
CATEGORY:=Mail
|
CATEGORY:=Mail
|
||||||
TITLE:=Postfix Mail Transmit Agent
|
TITLE:=Postfix Mail Transmit Agent
|
||||||
URL:=http://www.postfix.org/
|
URL:=http://www.postfix.org/
|
||||||
DEPENDS:=+POSTFIX_TLS:libopenssl +POSTFIX_SASL:libsasl2 +POSTFIX_LDAP:libopenldap +POSTFIX_DB:libdb47 +POSTFIX_EAI:icu +libpcre
|
DEPENDS:=+POSTFIX_TLS:libopenssl +POSTFIX_SASL:libsasl2 +POSTFIX_LDAP:libopenldap +POSTFIX_DB:libdb47 +POSTFIX_SQLITE:libsqlite3 +POSTFIX_EAI:icu +libpcre
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/postfix/description
|
define Package/postfix/description
|
||||||
|
@ -59,6 +59,11 @@ define Package/postfix/config
|
||||||
default y
|
default y
|
||||||
help
|
help
|
||||||
Implements support for cdb files using tinycdb
|
Implements support for cdb files using tinycdb
|
||||||
|
config POSTFIX_SQLITE
|
||||||
|
bool "SQLITE support"
|
||||||
|
default y
|
||||||
|
help
|
||||||
|
Implements support for SQLite3 DB
|
||||||
config POSTFIX_EAI
|
config POSTFIX_EAI
|
||||||
bool "SMTPUTF8 support"
|
bool "SMTPUTF8 support"
|
||||||
default n
|
default n
|
||||||
|
@ -106,6 +111,11 @@ else
|
||||||
CCARGS+=-DNO_DB
|
CCARGS+=-DNO_DB
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
ifdef CONFIG_POSTFIX_SQLITE
|
||||||
|
CCARGS+=-DHAS_SQLITE -I$(STAGING_DIR)/usr/include/
|
||||||
|
AUXLIBS+=-L$(STAGING_DIR)/usr/lib -lsqlite3 -lpthread
|
||||||
|
endif
|
||||||
|
|
||||||
ifdef CONFIG_POSTFIX_EAI
|
ifdef CONFIG_POSTFIX_EAI
|
||||||
AUXLIBS+=-licuuc
|
AUXLIBS+=-licuuc
|
||||||
CCARGS+=-DHAS_EAI
|
CCARGS+=-DHAS_EAI
|
||||||
|
|
10
mail/postfix/patches/501-include_stdio.patch
Normal file
10
mail/postfix/patches/501-include_stdio.patch
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/src/posttls-finger/posttls-finger.c
|
||||||
|
+++ b/src/posttls-finger/posttls-finger.c
|
||||||
|
@@ -318,6 +318,7 @@
|
||||||
|
#include <sys/un.h>
|
||||||
|
#include <netinet/in.h>
|
||||||
|
#include <arpa/inet.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
|
||||||
|
#ifdef STRCASECMP_IN_STRINGS_H
|
||||||
|
#include <strings.h>
|
Loading…
Reference in a new issue