Merge pull request #5842 from Andy2244/libtirpc
libtirpc: update to 1.0.3
This commit is contained in:
commit
67bfb98bed
7 changed files with 13 additions and 87 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libtirpc
|
||||
PKG_VERSION:=1.0.2
|
||||
PKG_VERSION:=1.0.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=@SF/libtirpc
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_HASH:=723c5ce92706cbb601a8db09110df1b4b69391643158f20ff587e20e7c5f90f5
|
||||
PKG_HASH:=86c3a78fc1bddefa96111dd233124c703b22a78884203c55c3e06b3be6a0fd5e
|
||||
|
||||
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
From 20badc3e3608953fb5b36bb2e16fa51bd731aebc Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Tue, 18 Apr 2017 09:35:35 -0700
|
||||
Subject: [PATCH] replace __bzero() with memset() API
|
||||
|
||||
memset is available across all libc implementation
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
Upstream-Status: Pending
|
||||
|
||||
src/des_impl.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/des_impl.c b/src/des_impl.c
|
||||
index 9dbccaf..15bec2a 100644
|
||||
--- a/src/des_impl.c
|
||||
+++ b/src/des_impl.c
|
||||
@@ -588,7 +588,7 @@ _des_crypt (char *buf, unsigned len, struct desparams *desp)
|
||||
}
|
||||
tin0 = tin1 = tout0 = tout1 = xor0 = xor1 = 0;
|
||||
tbuf[0] = tbuf[1] = 0;
|
||||
- __bzero (schedule, sizeof (schedule));
|
||||
+ memset (schedule, 0, sizeof (schedule));
|
||||
|
||||
return (1);
|
||||
}
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -1,24 +0,0 @@
|
|||
Add key_secretkey_is_set to exported symbols map
|
||||
|
||||
key_secret_is_set is a typo in libtirpc map
|
||||
Patch taken from
|
||||
|
||||
https://sourceforge.net/p/libtirpc/discussion/637321/thread/fd73d431/
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
|
||||
Index: libtirpc-1.0.1/src/libtirpc.map
|
||||
===================================================================
|
||||
--- libtirpc-1.0.1.orig/src/libtirpc.map
|
||||
+++ libtirpc-1.0.1/src/libtirpc.map
|
||||
@@ -298,7 +298,7 @@ TIRPC_0.3.2 {
|
||||
key_gendes;
|
||||
key_get_conv;
|
||||
key_setsecret;
|
||||
- key_secret_is_set;
|
||||
+ key_secretkey_is_set;
|
||||
key_setnet;
|
||||
netname2host;
|
||||
netname2user;
|
11
libs/libtirpc/patches/04-musl-rpc-fix-types.h.patch
Normal file
11
libs/libtirpc/patches/04-musl-rpc-fix-types.h.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/tirpc/rpc/types.h 2018-03-27
|
||||
+++ b/tirpc/rpc/types.h 2018-03-27
|
||||
@@ -66,7 +66,7 @@ typedef int32_t rpc_inline_t;
|
||||
#define mem_free(ptr, bsize) free(ptr)
|
||||
|
||||
|
||||
-#if defined __APPLE_CC__ || defined __FreeBSD__
|
||||
+#if defined __APPLE_CC__ || defined __FreeBSD__ || defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
|
||||
# define __u_char_defined
|
||||
# define __daddr_t_defined
|
||||
#endif
|
|
@ -1,31 +0,0 @@
|
|||
From 18f8a605e176f0362da22fd1203eb7cedb136aaf Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Tue, 20 Jun 2017 22:06:35 +0200
|
||||
Subject: [PATCH] include stdint.h for uintptr_t
|
||||
|
||||
Fixes
|
||||
| ../../libtirpc-1.0.1/src/xdr_sizeof.c:93:13: error: 'uintptr_t' undeclared (first use in this function); did you mean '__intptr_t'?
|
||||
| if (len < (uintptr_t)xdrs->x_base) {
|
||||
| ^~~~~~~~~
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
Signed-off-by: Dmitrii Kolesnichenko <dmitrii@synopsys.com>
|
||||
---
|
||||
src/xdr_sizeof.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/xdr_sizeof.c b/src/xdr_sizeof.c
|
||||
index d23fbd1..79d6707 100644
|
||||
--- a/src/xdr_sizeof.c
|
||||
+++ b/src/xdr_sizeof.c
|
||||
@@ -39,6 +39,7 @@
|
||||
#include <rpc/xdr.h>
|
||||
#include <sys/types.h>
|
||||
#include <stdlib.h>
|
||||
+#include <stdint.h>
|
||||
#include "un-namespace.h"
|
||||
|
||||
/* ARGSUSED */
|
||||
--
|
||||
2.9.4
|
||||
|
Loading…
Reference in a new issue