Merge pull request #10835 from TDT-AG/pr/20191219-net-tools-route
net-tools: add route utility
This commit is contained in:
commit
67a95d4984
2 changed files with 27 additions and 15 deletions
|
@ -1,10 +0,0 @@
|
|||
--- a/iptunnel.c 2016-07-10 20:15:29.000000000 +0200
|
||||
+++ b/iptunnel.c 2017-10-19 19:51:09.172782821 +0200
|
||||
@@ -26,7 +26,6 @@
|
||||
#include <sys/socket.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <netinet/in.h>
|
||||
-#include <netinet/ip.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <net/if.h>
|
||||
#include <net/if_arp.h>
|
|
@ -8,14 +8,14 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mii-tool
|
||||
PKG_SOURCE_DATE:=2016-10-06
|
||||
PKG_SOURCE_VERSION:=115f1af2494ded1fcd21c8419d5e289bc4df380f
|
||||
PKG_RELEASE:=3
|
||||
PKG_NAME:=net-tools
|
||||
PKG_SOURCE_DATE:=2018-11-03
|
||||
PKG_SOURCE_VERSION:=0eebece8c964e3cfa8a018f42b2e7e751a7009a0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://git.code.sf.net/p/net-tools/code
|
||||
PKG_MIRROR_HASH:=43d9d042ffe2db784256de5df8e77d688f0808f2b890351a21b902c798fa6310
|
||||
PKG_MIRROR_HASH:=9d978b9f8ccae4af623a299155c62d9b3d31213182c785f925bf8704d48a04c9
|
||||
|
||||
PKG_MAINTAINER:=Stijn Segers <borromini.reg@protonmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
@ -37,6 +37,22 @@ define Package/mii-tool/description
|
|||
optimized for embedded systems and fully automated cross/-sysroot-builds
|
||||
endef
|
||||
|
||||
define Package/net-tools-route
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=net-tools - route utility
|
||||
URL:=http://net-tools.sourceforge.net/
|
||||
PROVIDES:=route
|
||||
ALTERNATIVES:=300:/sbin/route:/usr/libexec/net-tools-route
|
||||
endef
|
||||
|
||||
define Package/net-tools-route/description
|
||||
Replace busybox version of the route command with the full net-tools
|
||||
version. This is normally not needed as busybox is smaller and provides
|
||||
sufficient functionality, but some users may want or need the full
|
||||
functionality of the net-tools variant (e.g. AF_X25).
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
# Failed configure.sh leaves stub config.h around.
|
||||
rm -f $(PKG_BUILD_DIR)/config.h
|
||||
|
@ -48,4 +64,10 @@ define Package/mii-tool/install
|
|||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mii-tool $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/net-tools-route/install
|
||||
$(INSTALL_DIR) $(1)/usr/libexec
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/route $(1)/usr/libexec/net-tools-route
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,mii-tool))
|
||||
$(eval $(call BuildPackage,net-tools-route))
|
Loading…
Reference in a new issue