setserial: Add missing headers
Fixes compilation with -Wimplicit-function-declaration Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
50abfa2fd7
commit
66c215799d
2 changed files with 21 additions and 3 deletions
|
@ -2,15 +2,14 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=setserial
|
||||
PKG_VERSION:=2.17
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/setserial
|
||||
PKG_HASH:=7e4487d320ac31558563424189435d396ddf77953bb23111a17a3d1487b5794a
|
||||
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
19
utils/setserial/patches/020-musl.patch
Normal file
19
utils/setserial/patches/020-musl.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- a/setserial.c
|
||||
+++ b/setserial.c
|
||||
@@ -11,6 +11,8 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <termios.h>
|
||||
#include <string.h>
|
||||
@@ -22,6 +24,7 @@
|
||||
#ifdef HAVE_LINUX_HAYESESP_H
|
||||
#include <linux/hayesesp.h>
|
||||
#endif
|
||||
+#include <sys/ioctl.h>
|
||||
#include <linux/serial.h>
|
||||
|
||||
#include "version.h"
|
Loading…
Reference in a new issue