ffmpeg: Update to 2.4.4
Drop fminf patch; fminf emulation is no longer included upstream. Signed-off-by: Ian Leonard <antonlacon@gmail.com>
This commit is contained in:
parent
65d8897100
commit
665cd72e82
2 changed files with 2 additions and 20 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ffmpeg
|
PKG_NAME:=ffmpeg
|
||||||
PKG_VERSION:=2.4.2
|
PKG_VERSION:=2.4.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://ffmpeg.org/releases/
|
PKG_SOURCE_URL:=http://ffmpeg.org/releases/
|
||||||
PKG_MD5SUM:=9e6163b09b7b9331b834d80874c2c0ff
|
PKG_MD5SUM:=7e2819c71484ffba1ba1a91dd5285643
|
||||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||||
|
|
||||||
PKG_LICENSE:=LGPL-2.1+ GPL-2+ LGPL-3
|
PKG_LICENSE:=LGPL-2.1+ GPL-2+ LGPL-3
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- a/libavutil/libm.h
|
|
||||||
+++ b/libavutil/libm.h
|
|
||||||
@@ -82,6 +82,7 @@ static av_always_inline float cbrtf(floa
|
|
||||||
#define exp2f(x) ((float)exp2(x))
|
|
||||||
#endif /* HAVE_EXP2F */
|
|
||||||
|
|
||||||
+/* ---------- BROKEN: Defined in math.h but not present in uClibc 0.9.33.2
|
|
||||||
#if !HAVE_FMINF
|
|
||||||
#undef fminf
|
|
||||||
static av_always_inline av_const float fminf(float x, float y)
|
|
||||||
@@ -91,6 +92,7 @@ static av_always_inline av_const float f
|
|
||||||
return x > y ? y : (x == x ? x : y);
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
+------------------------------------------------------------------------- */
|
|
||||||
|
|
||||||
#if !HAVE_ISINF
|
|
||||||
static av_always_inline av_const int isinf(float x)
|
|
Loading…
Reference in a new issue