haproxy: Update HAProxy to v1.8.27
- Update haproxy download URL and hash - Fix ssl compat patch offsets Signed-off-by: Christian Lachner <gladiac@gmail.com>
This commit is contained in:
parent
3325a3ce01
commit
65e9199966
3 changed files with 10 additions and 10 deletions
|
@ -10,12 +10,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=haproxy
|
||||
PKG_VERSION:=1.8.26
|
||||
PKG_VERSION:=1.8.27
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.haproxy.org/download/1.8/src/
|
||||
PKG_HASH:=e3c2a81b6f26dcb736a34ebb5f134d3251ceccf30386214655fa7ed6d3afa400
|
||||
PKG_HASH:=56ba6a21e13215fae56472ad37d5d68c3f19bde9da94c59e70b869eecf48bf50
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
#!/bin/bash
|
||||
|
||||
CLONEURL=http://git.haproxy.org/git/haproxy-1.8.git
|
||||
BASE_TAG=v1.8.26
|
||||
BASE_TAG=v1.8.27
|
||||
TMP_REPODIR=tmprepo
|
||||
PATCHESDIR=patches
|
||||
|
||||
|
|
|
@ -35,7 +35,7 @@
|
|||
|
||||
static HA_RWLOCK_T *ssl_rwlocks;
|
||||
|
||||
@@ -1716,8 +1728,8 @@ ssl_sock_do_create_cert(const char *servername, struct bind_conf *bind_conf, SSL
|
||||
@@ -1720,8 +1732,8 @@ ssl_sock_do_create_cert(const char *servername, struct bind_conf *bind_conf, SSL
|
||||
ASN1_INTEGER_set(X509_get_serialNumber(newcrt), HA_ATOMIC_ADD(&ssl_ctx_serial, 1));
|
||||
|
||||
/* Set duration for the certificate */
|
||||
|
@ -46,7 +46,7 @@
|
|||
goto mkcert_error;
|
||||
|
||||
/* set public key in the certificate */
|
||||
@@ -6387,7 +6399,7 @@ smp_fetch_ssl_x_notafter(const struct arg *args, struct sample *smp, const char
|
||||
@@ -6395,7 +6407,7 @@ smp_fetch_ssl_x_notafter(const struct arg *args, struct sample *smp, const char
|
||||
goto out;
|
||||
|
||||
smp_trash = get_trash_chunk();
|
||||
|
@ -55,7 +55,7 @@
|
|||
goto out;
|
||||
|
||||
smp->data.u.str = *smp_trash;
|
||||
@@ -6487,7 +6499,7 @@ smp_fetch_ssl_x_notbefore(const struct a
|
||||
@@ -6495,7 +6507,7 @@ smp_fetch_ssl_x_notbefore(const struct a
|
||||
goto out;
|
||||
|
||||
smp_trash = get_trash_chunk();
|
||||
|
@ -64,7 +64,7 @@
|
|||
goto out;
|
||||
|
||||
smp->data.u.str = *smp_trash;
|
||||
@@ -9068,7 +9080,9 @@ static void __ssl_sock_init(void)
|
||||
@@ -9076,7 +9088,9 @@ static void __ssl_sock_init(void)
|
||||
#endif
|
||||
|
||||
xprt_register(XPRT_SSL, &ssl_sock);
|
||||
|
@ -74,7 +74,7 @@
|
|||
#if (!defined(OPENSSL_NO_COMP) && !defined(SSL_OP_NO_COMPRESSION))
|
||||
cm = SSL_COMP_get_compression_methods();
|
||||
i = sk_SSL_COMP_num(cm);
|
||||
@@ -9077,7 +9091,7 @@ static void __ssl_sock_init(void)
|
||||
@@ -9085,7 +9099,7 @@ static void __ssl_sock_init(void)
|
||||
}
|
||||
#endif
|
||||
|
||||
|
@ -83,7 +83,7 @@
|
|||
ssl_locking_init();
|
||||
#endif
|
||||
#if (OPENSSL_VERSION_NUMBER >= 0x1000200fL && !defined OPENSSL_NO_TLSEXT && !defined OPENSSL_IS_BORINGSSL && !defined LIBRESSL_VERSION_NUMBER)
|
||||
@@ -9106,8 +9120,8 @@ static void __ssl_sock_init(void)
|
||||
@@ -9114,8 +9128,8 @@ static void __ssl_sock_init(void)
|
||||
#else /* OPENSSL_IS_BORINGSSL */
|
||||
OPENSSL_VERSION_TEXT
|
||||
"\nRunning on OpenSSL version : %s%s",
|
||||
|
@ -94,7 +94,7 @@
|
|||
#endif
|
||||
memprintf(&ptr, "%s\nOpenSSL library supports TLS extensions : "
|
||||
#if OPENSSL_VERSION_NUMBER < 0x00907000L
|
||||
@@ -9198,12 +9212,14 @@ static void __ssl_sock_deinit(void)
|
||||
@@ -9206,12 +9220,14 @@ static void __ssl_sock_deinit(void)
|
||||
}
|
||||
#endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue