btrfs-progs: update to version 4.5.1
musl pthread patch imported from alpinelinux.org Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
89f3a24a3f
commit
656f2eb5a7
2 changed files with 14 additions and 3 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=btrfs-progs
|
||||
PKG_VERSION:=3.19.1
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=4.5.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs/
|
||||
PKG_MD5SUM:=ec3b3c99df18633ddc9e41f0680c5a51
|
||||
PKG_MD5SUM:=31be62e9a772f297669b2ee14dc85c27
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- btrfs-progs-v4.2.3/chunk-recover.c
|
||||
+++ btrfs-progs-v4.2.3/chunk-recover.c.new
|
||||
@@ -883,7 +883,7 @@
|
||||
for (i = 0; i < devidx; i++) {
|
||||
if (dev_scans[i].bytenr == -1)
|
||||
continue;
|
||||
- ret = pthread_tryjoin_np(t_scans[i],
|
||||
+ ret = pthread_join(t_scans[i],
|
||||
(void **)&t_rets[i]);
|
||||
if (ret == EBUSY) {
|
||||
all_done = 0;
|
Loading…
Reference in a new issue