lcdproc: fix compilation with GCC 10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
11c4323665
commit
650b996dc0
2 changed files with 22 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=lcdproc
|
||||
PKG_VERSION:=0.5.9
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/lcdproc/lcdproc/releases/download/v$(PKG_VERSION)/
|
||||
|
|
21
utils/lcdproc/patches/120-gcc10.patch
Normal file
21
utils/lcdproc/patches/120-gcc10.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- a/clients/lcdproc/iface.c
|
||||
+++ b/clients/lcdproc/iface.c
|
||||
@@ -32,6 +32,7 @@
|
||||
#define UNSET_INT -1
|
||||
#define UNSET_STR "\01"
|
||||
|
||||
+IfaceInfo iface[MAX_INTERFACES];
|
||||
|
||||
static int iface_count = 0; /* number of interfaces */
|
||||
static char unit_label[10] = "B"; /* default unit label is Bytes */
|
||||
--- a/clients/lcdproc/iface.h
|
||||
+++ b/clients/lcdproc/iface.h
|
||||
@@ -18,7 +18,7 @@
|
||||
/** max number of interfaces in multi-interface mode */
|
||||
#define MAX_INTERFACES 3
|
||||
|
||||
-IfaceInfo iface[MAX_INTERFACES]; /* interface info */
|
||||
+extern IfaceInfo iface[MAX_INTERFACES]; /* interface info */
|
||||
|
||||
/** Update screen content */
|
||||
int iface_screen(int rep, int display, int *flags_ptr);
|
Loading…
Reference in a new issue