iputils: Fix version reporting
The iputils build system embeds git tags into the generated binaries for use by commands like ping -V. Since openwrt packaging is done in a different repository from the upstream repo, the tags it finds aren't particularly meaningful, and we get confusing results like those described at https://github.com/openwrt/packages/issues/13920 This change removes the git tag inspection in favor of the static version string that's already known to the upstream build system. Signed-off-by: Noah Meyerhans <frodo@morgul.net>
This commit is contained in:
parent
abb0501e28
commit
64ed17c88c
1 changed files with 24 additions and 0 deletions
24
net/iputils/patches/001_version_fix.patch
Normal file
24
net/iputils/patches/001_version_fix.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
Description: set a static version string rather than discern it from git
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -17,6 +17,7 @@ add_project_arguments(
|
||||
|
||||
conf = configuration_data()
|
||||
conf.set_quoted('PACKAGE_NAME', meson.project_name())
|
||||
+conf.set('VCS_TAG', meson.project_version())
|
||||
conf.set('_GNU_SOURCE', 1, description : 'Enable GNU extensions on systems that have them.')
|
||||
|
||||
build_arping = get_option('BUILD_ARPING')
|
||||
@@ -207,10 +208,10 @@ foreach h : [
|
||||
endif
|
||||
endforeach
|
||||
|
||||
-git_version_h = vcs_tag(
|
||||
+git_version_h = configure_file(
|
||||
input : 'git-version.h.meson',
|
||||
output : 'git-version.h',
|
||||
- fallback : meson.project_version()
|
||||
+ configuration: conf
|
||||
)
|
||||
|
||||
config_h = configure_file(
|
Loading…
Reference in a new issue