Merge pull request #8152 from diizzyy/sound/fdk-aac-20
sound/fdk-aac: Update to 2.0.0
This commit is contained in:
commit
64c94b329f
2 changed files with 3 additions and 32 deletions
|
@ -6,15 +6,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=fdk-aac
|
PKG_NAME:=fdk-aac
|
||||||
PKG_VERSION:=0.1.6
|
PKG_VERSION:=2.0.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||||
PKG_LICENSE:=Fraunhofer-FDK-AAC-for-Android
|
PKG_LICENSE:=Fraunhofer-FDK-AAC-for-Android
|
||||||
PKG_LICENSE_FILES:=NOTICE
|
PKG_LICENSE_FILES:=NOTICE
|
||||||
|
|
||||||
PKG_SOURCE_URL=https://codeload.github.com/mstorsjo/fdk-aac/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL=https://codeload.github.com/mstorsjo/fdk-aac/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_HASH:=adbcd793e406e1b88b3c1c41382d49f8c27371485b823c0fdab69c9124fd2ce3
|
PKG_HASH:=6e6c7921713788e31df655911e1d42620b057180b00bf16874f5d630e1d5b9a2
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
From a50eecf65b5ce5d4f03768c5c2cb4b492d2badad Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Storsjo <martin@martin.st>
|
|
||||||
Date: Fri, 4 May 2018 12:46:44 +0300
|
|
||||||
Subject: [PATCH] Fix overflows in accumulation, fixing crashes
|
|
||||||
|
|
||||||
This fixes github issue #83.
|
|
||||||
---
|
|
||||||
libSBRenc/src/tran_det.cpp | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libSBRenc/src/tran_det.cpp b/libSBRenc/src/tran_det.cpp
|
|
||||||
index 0e35ec3..51d6efe 100644
|
|
||||||
--- a/libSBRenc/src/tran_det.cpp
|
|
||||||
+++ b/libSBRenc/src/tran_det.cpp
|
|
||||||
@@ -256,12 +256,12 @@ static FIXP_DBL addLowbandEnergies(FIXP_DBL **Energies,
|
|
||||||
/* freqBandTable[LORES] has MAX_FREQ_COEFFS/2 +1 coeefs max. */
|
|
||||||
for (ts=tran_offdiv2; ts<YBufferWriteOffset; ts++) {
|
|
||||||
for (k = 0; k < freqBandTable[0]; k++) {
|
|
||||||
- accu1 += Energies[ts][k] >> 6;
|
|
||||||
+ accu1 = fAddSaturate(accu1, Energies[ts][k] >> 6);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
for (; ts<tran_offdiv2+(slots>>nrgSzShift); ts++) {
|
|
||||||
for (k = 0; k < freqBandTable[0]; k++) {
|
|
||||||
- accu2 += Energies[ts][k] >> 9;
|
|
||||||
+ accu2 = fAddSaturate(accu2, Energies[ts][k] >> 9);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in a new issue