diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index 36b108338..d2ceae3c1 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zabbix
-PKG_VERSION:=4.0.6
-PKG_RELEASE:=2
+PKG_VERSION:=4.0.11
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/zabbix
-PKG_HASH:=2890851b3a4b0f70f69ef754aa0d07070b42440f56d280113a9474bc4ed75e5b
+PKG_HASH:=b0af25c31c622d14cb7780db5941d76579b9f9a6ee449613d847b0b505628409
 
 PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
 PKG_LICENSE:=GPL-2.0
diff --git a/admin/zabbix/patches/003-change-user-and-foreground.patch b/admin/zabbix/patches/003-change-user-and-foreground.patch
deleted file mode 100644
index 6779e4719..000000000
--- a/admin/zabbix/patches/003-change-user-and-foreground.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/libs/zbxnix/daemon.c
-+++ b/src/libs/zbxnix/daemon.c
-@@ -300,11 +300,14 @@ int	daemon_start(int allow_root, const c
- 
- 	if (0 == allow_root && 0 == getuid())	/* running as root? */
- 	{
-+#if 0
-+/* allow changing user and foreground */
- 		if (0 != (flags & ZBX_TASK_FLAG_FOREGROUND))
- 		{
- 			zbx_error("cannot run as root!");
- 			exit(EXIT_FAILURE);
- 		}
-+#endif
- 
- 		if (NULL == user)
- 			user = "zabbix";