mbtools: fix compilation with newer glib
Remove Werror as glib throws deprecation warnings. Cleaned up Makefile for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
0960a401d8
commit
647721c61e
2 changed files with 20 additions and 12 deletions
|
@ -8,25 +8,22 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mbtools
|
||||
|
||||
PKG_VERSION:=2014-10-29
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
PKG_SOURCE_DATE:=2014-10-29
|
||||
PKG_SOURCE_VERSION:=149e9c69cec180f18cf8781cf5285b97352bf719
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/webstack/mbtools.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=149e9c69cec180f18cf8781cf5285b97352bf719
|
||||
PKG_MIRROR_HASH:=3aed4146e06bd9f9bcc271824c6b1d75d1fc2a0bd980f2b729c3b4755c6f70a8
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_SOURCE_URL:=https://github.com/webstack/mbtools
|
||||
PKG_MIRROR_HASH:=3f6a452d59a62b4f582020ebf1e371f0f0c94d99b1b056af3c4e124426a7a772
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
|
|
11
utils/mbtools/patches/010-glib.patch
Normal file
11
utils/mbtools/patches/010-glib.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -21,7 +21,7 @@ AC_CHECK_HEADERS([stdio.h stdlib.h string.h unistd.h])
|
||||
|
||||
MBTOOLS_REQUIRES="glib-2.0 >= 2.10.0 libmodbus >= 3.1.0"
|
||||
PKG_CHECK_MODULES(MBTOOLS_DEPS, [$MBTOOLS_REQUIRES])
|
||||
-MBTOOLS_CFLAGS="-Wall -Werror $MBTOOLS_DEPS_CFLAGS"
|
||||
+MBTOOLS_CFLAGS="-Wall $MBTOOLS_DEPS_CFLAGS"
|
||||
MBTOOLS_LIBS="$MBTOOLS_DEPS_LIBS"
|
||||
AC_SUBST(MBTOOLS_CFLAGS)
|
||||
AC_SUBST(MBTOOLS_LIBS)
|
Loading…
Reference in a new issue