xinetd: fix musl compatibility
Pass HAVE_RLIM_T via TARGET_CPPFLAGS since configure uses that define but never actually declares it. Without doing that, `config.h` tries to declare `rlim_t` itself which leads to `config.h:126:16: error: 'long long long' is too long for GCC` with musl on at least x86_64. Also refresh patches while we're at it. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
This commit is contained in:
parent
4116e327af
commit
644ae71ebc
2 changed files with 5 additions and 4 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2014 OpenWrt.org
|
# Copyright (C) 2006-2015 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=xinetd
|
PKG_NAME:=xinetd
|
||||||
PKG_VERSION:=2.3.15
|
PKG_VERSION:=2.3.15
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.xinetd.org
|
PKG_SOURCE_URL:=http://www.xinetd.org
|
||||||
|
@ -42,6 +42,7 @@ define Package/xinetd/conffiles
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += -DNO_RPC
|
TARGET_CFLAGS += -DNO_RPC
|
||||||
|
TARGET_CPPFLAGS += -DHAVE_RLIM_T
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--without-libwrap \
|
--without-libwrap \
|
||||||
|
|
|
@ -10,7 +10,7 @@ Reviewed-By: Adam Tkac <atkac@redhat.com>
|
||||||
#diff -up xinetd-2.3.14/xinetd/ident.c.orig xinetd-2.3.14/xinetd/ident.c
|
#diff -up xinetd-2.3.14/xinetd/ident.c.orig xinetd-2.3.14/xinetd/ident.c
|
||||||
--- a/xinetd/ident.c
|
--- a/xinetd/ident.c
|
||||||
+++ b/xinetd/ident.c
|
+++ b/xinetd/ident.c
|
||||||
@@ -97,7 +98,13 @@ idresult_e log_remote_user( const struct
|
@@ -97,7 +97,13 @@ idresult_e log_remote_user( const struct
|
||||||
}
|
}
|
||||||
|
|
||||||
CLEAR( sin_contact );
|
CLEAR( sin_contact );
|
||||||
|
@ -25,7 +25,7 @@ Reviewed-By: Adam Tkac <atkac@redhat.com>
|
||||||
sin_contact = sin_remote;
|
sin_contact = sin_remote;
|
||||||
memcpy( &sin_bind, &sin_local, sizeof(sin_bind) ) ;
|
memcpy( &sin_bind, &sin_local, sizeof(sin_bind) ) ;
|
||||||
local_port = 0;
|
local_port = 0;
|
||||||
@@ -121,7 +128,13 @@ idresult_e log_remote_user( const struct
|
@@ -127,7 +133,13 @@ idresult_e log_remote_user( const struct
|
||||||
msg( LOG_ERR, func, "socket creation: %m" ) ;
|
msg( LOG_ERR, func, "socket creation: %m" ) ;
|
||||||
return( IDR_ERROR ) ;
|
return( IDR_ERROR ) ;
|
||||||
}
|
}
|
||||||
|
|
Loading…
Reference in a new issue