mpd: update to 0.23.8
Simplify iconv patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
88a10af17f
commit
63ba2ccbda
2 changed files with 17 additions and 19 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mpd
|
||||
PKG_VERSION:=0.23.5
|
||||
PKG_VERSION:=0.23.8
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpd/0.23
|
||||
PKG_HASH:=f22c2c25093a05f4566f9cd7207cfbcd8405af67ed29a989bcf8905f80b7a299
|
||||
PKG_HASH:=86bb569bf3b519821f36f6bb5564e484e85d2564411b34b200fe2cd3a04e78cf
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -18,24 +18,22 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|||
|
||||
--- a/src/lib/icu/meson.build
|
||||
+++ b/src/lib/icu/meson.build
|
||||
@@ -18,8 +18,18 @@ if icu_dep.found()
|
||||
@@ -19,16 +19,8 @@ if icu_dep.found()
|
||||
'Init.cxx',
|
||||
]
|
||||
elif not get_option('iconv').disabled()
|
||||
- have_iconv = compiler.has_function('iconv', prefix : '#include <iconv.h>')
|
||||
- # an installed iconv library will make the builtin iconv() unavailable,
|
||||
- # so search for the library first and pass it as (possible) dependency
|
||||
- iconv_dep = compiler.find_library('libiconv', required: false)
|
||||
- have_iconv = compiler.has_function('iconv',
|
||||
- dependencies: iconv_dep,
|
||||
- prefix : '#include <iconv.h>')
|
||||
- if not have_iconv and get_option('iconv').enabled()
|
||||
- error('iconv() not available')
|
||||
- endif
|
||||
- conf.set('HAVE_ICONV', have_iconv)
|
||||
+ have_iconv = c_compiler.has_header_symbol('iconv.h', 'iconv')
|
||||
+ if have_iconv
|
||||
+ libiconv = c_compiler.find_library('iconv', required : false)
|
||||
+ conf.set('HAVE_ICONV', have_iconv)
|
||||
+ libiconv_dep = static_library('iconv', icu_sources, include_directories: inc, dependencies: libiconv)
|
||||
+ icu_dep = declare_dependency(link_with: libiconv_dep, dependencies: util_dep)
|
||||
+ endif
|
||||
+ if not have_iconv and c_compiler.has_function('iconv')
|
||||
+ libiconv = []
|
||||
+ have_iconv = true
|
||||
+ conf.set('HAVE_ICONV', have_iconv)
|
||||
+ endif
|
||||
if not have_iconv and get_option('iconv').enabled()
|
||||
error('iconv() not available')
|
||||
+ iconv_dep = dependency('iconv')
|
||||
+ conf.set('HAVE_ICONV', iconv_dep.found())
|
||||
endif
|
||||
|
||||
icu = static_library(
|
||||
|
|
Loading…
Reference in a new issue