quota: update to 4.09
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
72f683ec27
commit
63816dab84
3 changed files with 2 additions and 31 deletions
utils/quota
|
@ -6,12 +6,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=quota
|
PKG_NAME:=quota
|
||||||
PKG_VERSION:=4.06
|
PKG_VERSION:=4.09
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/linuxquota
|
PKG_SOURCE_URL:=@SF/linuxquota
|
||||||
PKG_HASH:=2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d
|
PKG_HASH:=9cdaca154bc92afc3117f0e5f5b3208dd5f84583af1cf061c39baa0a2bb142f9
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- a/quota.h
|
|
||||||
+++ b/quota.h
|
|
||||||
@@ -1,7 +1,6 @@
|
|
||||||
#ifndef GUARD_QUOTA_H
|
|
||||||
#define GUARD_QUOTA_H
|
|
||||||
|
|
||||||
-#include <sys/cdefs.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <stdint.h>
|
|
||||||
|
|
||||||
@@ -182,6 +181,6 @@ enum {
|
|
||||||
#endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-long quotactl __P((int, const char *, qid_t, caddr_t));
|
|
||||||
+long quotactl (int, const char *, qid_t, caddr_t);
|
|
||||||
|
|
||||||
#endif /* _QUOTA_ */
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/quota.c
|
|
||||||
+++ b/quota.c
|
|
||||||
@@ -385,7 +385,7 @@ int main(int argc, char **argv)
|
|
||||||
break;
|
|
||||||
case 259:
|
|
||||||
fscount++;
|
|
||||||
- fsnames = reallocarray(fsnames, fscount, sizeof(char *));
|
|
||||||
+ fsnames = realloc(fsnames, fscount * sizeof(char *));
|
|
||||||
if (!fsnames)
|
|
||||||
die(1, _("Not enough memory for filesystem names"));
|
|
||||||
fsnames[fscount - 1] = optarg;
|
|
Loading…
Reference in a new issue