python-twisted: Update to 20.3.0, refresh patches
This update includes fixes for: * CVE-2020-10108 * CVE-2020-10109 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
6408a0c585
commit
633c81e7a9
3 changed files with 11 additions and 11 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-twisted
|
||||
PKG_VERSION:=19.10.0
|
||||
PKG_VERSION:=20.3.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=Twisted
|
||||
PYPI_SOURCE_EXT:=tar.bz2
|
||||
PKG_HASH:=7394ba7f272ae722a74f3d969dcf599bc4ef093bc392038748a490f1724a515d
|
||||
PKG_HASH:=d72c55b5d56e176563b91d11952d13b01af8725c623e498db5507b6614fc1e10
|
||||
|
||||
PKG_BUILD_DEPENDS:=libtirpc
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/twisted/python/_setup.py
|
||||
+++ b/src/twisted/python/_setup.py
|
||||
@@ -150,7 +150,6 @@ _CONSOLE_SCRIPTS = [
|
||||
@@ -151,7 +151,6 @@ _CONSOLE_SCRIPTS = [
|
||||
"conch = twisted.conch.scripts.conch:run",
|
||||
"mailmail = twisted.mail.scripts.mailmail:run",
|
||||
"pyhtmlizer = twisted.scripts.htmlizer:run",
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/twisted/python/_setup.py
|
||||
+++ b/src/twisted/python/_setup.py
|
||||
@@ -176,11 +176,6 @@ class ConditionalExtension(Extension, ob
|
||||
@@ -177,11 +177,6 @@ class ConditionalExtension(Extension, ob
|
||||
# The C extensions used for Twisted.
|
||||
_EXTENSIONS = [
|
||||
ConditionalExtension(
|
||||
|
@ -12,12 +12,12 @@
|
|||
"twisted.internet.iocpreactor.iocpsupport",
|
||||
sources=[
|
||||
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
|
||||
@@ -285,12 +280,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
|
||||
"incremental >= 16.10.1",
|
||||
"Automat >= 0.3.0",
|
||||
"hyperlink >= 17.1.1",
|
||||
- "PyHamcrest >= 1.9.0",
|
||||
"attrs >= 17.4.0",
|
||||
@@ -275,12 +270,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
|
||||
# PyHamcrest 1.10.0 is Python 3 only, but lacks package metadata that
|
||||
# says so. This condition can be dropped when Twisted drops support for
|
||||
# Python 2.7.
|
||||
- "PyHamcrest >= 1.9.0, != 1.10.0",
|
||||
"attrs >= 19.2.0",
|
||||
]
|
||||
|
||||
arguments.update(dict(
|
||||
|
@ -26,7 +26,7 @@
|
|||
use_incremental=True,
|
||||
setup_requires=["incremental >= 16.10.1"],
|
||||
install_requires=requirements,
|
||||
@@ -300,7 +294,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
|
||||
@@ -290,7 +284,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
|
||||
cmdclass=command_classes,
|
||||
include_package_data=True,
|
||||
exclude_package_data={
|
||||
|
|
Loading…
Reference in a new issue