crelay: Update to 0.10, refresh patches, remove daemon background call
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
bc9795a27f
commit
625a7e7563
5 changed files with 26 additions and 7 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2015 OpenWrt.org
|
# Copyright (C) 2015-2016 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=crelay
|
PKG_NAME:=crelay
|
||||||
PKG_VERSION:=0.9
|
PKG_VERSION:=0.10
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
|
@ -40,7 +40,8 @@ define Package/crelay/description
|
||||||
.
|
.
|
||||||
Currently supported relay cards:
|
Currently supported relay cards:
|
||||||
- Conrad USB 4-channel relay card
|
- Conrad USB 4-channel relay card
|
||||||
- Sainsmart USB 4-channel relay card
|
- Sainsmart USB 4/8-channel relay board
|
||||||
|
- Sainsmart USB 16-channel relay control module
|
||||||
- Generic GPIO relays
|
- Generic GPIO relays
|
||||||
- HID API compatible relay card
|
- HID API compatible relay card
|
||||||
endef
|
endef
|
||||||
|
|
|
@ -13,6 +13,9 @@ USE_PROCD=1
|
||||||
start_service() {
|
start_service() {
|
||||||
procd_open_instance
|
procd_open_instance
|
||||||
|
|
||||||
|
# restart if it croaks
|
||||||
|
procd_set_param respawn
|
||||||
|
|
||||||
procd_set_param command "$PROG"
|
procd_set_param command "$PROG"
|
||||||
# daemon mode (not daemonized) - starts HTTP server
|
# daemon mode (not daemonized) - starts HTTP server
|
||||||
procd_append_param command -d
|
procd_append_param command -d
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -45,7 +45,7 @@ endif
|
@@ -44,7 +44,7 @@ OPTS += -DDRV_CONRAD
|
||||||
#ifdef DRV_SAINSMART
|
endif
|
||||||
ifeq ($(DRV_SAINSMART), y)
|
ifeq ($(DRV_SAINSMART), y)
|
||||||
SRC += relay_drv_sainsmart.c
|
SRC += relay_drv_sainsmart.c
|
||||||
-LIBS += -lftdi
|
-LIBS += -lftdi
|
||||||
+LIBS += -lftdi1
|
+LIBS += -lftdi1
|
||||||
OPTS += -DDRV_SAINSMART
|
OPTS += -DDRV_SAINSMART
|
||||||
endif
|
endif
|
||||||
#ifdef DRV_HIDAPI
|
ifeq ($(DRV_SAINSMART16), y)
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -61,7 +61,7 @@ all: $(BIN)
|
@@ -64,7 +64,7 @@ all: $(BIN)
|
||||||
|
|
||||||
$(BIN): $(OBJ)
|
$(BIN): $(OBJ)
|
||||||
@echo "[Link $(BIN)] with libs $(LIBS)"
|
@echo "[Link $(BIN)] with libs $(LIBS)"
|
||||||
|
|
15
utils/crelay/patches/030-remove_daemonize_call.patch
Normal file
15
utils/crelay/patches/030-remove_daemonize_call.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
--- a/src/crelay.c
|
||||||
|
+++ b/src/crelay.c
|
||||||
|
@@ -678,10 +678,12 @@ int main(int argc, char *argv[])
|
||||||
|
listen(sock, 5);
|
||||||
|
syslog(LOG_DAEMON | LOG_NOTICE, "HTTP server listening on %s:%d\n", inet_ntoa(iface), port);
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
if (daemon(0, 0) == -1) {
|
||||||
|
syslog(LOG_DAEMON | LOG_ERR, "Failed to daemonize: %s", strerror(errno));
|
||||||
|
exit(EXIT_FAILURE);
|
||||||
|
}
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
while (1)
|
||||||
|
{
|
Loading…
Reference in a new issue