wavemon: update to v0.8.0
Requires small changes to the included header files in order to build successfully using musl. Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
This commit is contained in:
parent
8eae2489b0
commit
620e8fe8c7
2 changed files with 25 additions and 4 deletions
|
@ -8,8 +8,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wavemon
|
||||
PKG_VERSION:=0.7.6
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.8.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_PROTO:=git
|
||||
|
@ -30,7 +30,7 @@ define Package/wavemon
|
|||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=N-curses based wireless network devices monitor
|
||||
DEPENDS:=+libncurses +libpthread
|
||||
DEPENDS:=+libncurses +libpthread +libnl-genl
|
||||
SUBMENU:=wireless
|
||||
URL:=https://github.com/uoaerg/wavemon/releases
|
||||
endef
|
||||
|
@ -45,7 +45,7 @@ endef
|
|||
CONFIGURE_VARS += \
|
||||
ac_cv_lib_cap_cap_get_flag=no
|
||||
|
||||
TARGET_CFLAGS += -pthread
|
||||
TARGET_CFLAGS += -pthread -I/usr/include/libnl3
|
||||
|
||||
MAKE_FLAGS += \
|
||||
CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include"
|
||||
|
|
21
net/wavemon/patches/musl-fix.patch
Normal file
21
net/wavemon/patches/musl-fix.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff --git a/wavemon.h b/wavemon.h
|
||||
index e7584f7..8c76d11 100644
|
||||
--- a/wavemon.h
|
||||
+++ b/wavemon.h
|
||||
@@ -19,6 +19,7 @@
|
||||
* Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
#include <stdio.h>
|
||||
+#include <stdint.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
#include <signal.h>
|
||||
@@ -33,7 +34,7 @@
|
||||
#include <ctype.h>
|
||||
#include <math.h>
|
||||
#include <stdbool.h>
|
||||
-#include <ncurses.h>
|
||||
+#include <curses.h>
|
||||
|
||||
#include "llist.h"
|
||||
|
Loading…
Reference in a new issue