git: update to 2.14.0
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
568882c31a
commit
61f48f8df8
3 changed files with 7 additions and 7 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=git
|
||||
PKG_VERSION:=2.13.3
|
||||
PKG_VERSION:=2.14.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
||||
PKG_HASH:=91aa23be428f67eb19616f43fa0229d567e9acf4f08fba33eb0b627e4d323e62
|
||||
PKG_HASH:=f93e6e6a307d2e953cccafd9f4003c62992628fa508d07586476c953c1655975
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -869,7 +869,8 @@ AC_RUN_IFELSE(
|
||||
@@ -926,7 +926,8 @@ AC_RUN_IFELSE(
|
||||
FILE *f = fopen(".", "r");
|
||||
return f && fread(&c, 1, 1, f)]])],
|
||||
return f)]])],
|
||||
[ac_cv_fread_reads_directories=no],
|
||||
- [ac_cv_fread_reads_directories=yes])
|
||||
+ [ac_cv_fread_reads_directories=yes],
|
||||
|
@ -10,7 +10,7 @@
|
|||
])
|
||||
if test $ac_cv_fread_reads_directories = yes; then
|
||||
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
||||
@@ -903,7 +904,8 @@ AC_RUN_IFELSE(
|
||||
@@ -960,7 +961,8 @@ AC_RUN_IFELSE(
|
||||
if (snprintf(buf, 3, "%s", "12345") != 5
|
||||
|| strcmp(buf, "12")) return 1]])],
|
||||
[ac_cv_snprintf_returns_bogus=no],
|
||||
|
@ -20,7 +20,7 @@
|
|||
])
|
||||
if test $ac_cv_snprintf_returns_bogus = yes; then
|
||||
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
||||
@@ -926,7 +928,8 @@ yippeeyeswehaveit
|
||||
@@ -983,7 +985,8 @@ yippeeyeswehaveit
|
||||
#endif
|
||||
]),
|
||||
[ac_cv_sane_mode_bits=yes],
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1137,7 +1137,7 @@ else
|
||||
@@ -1197,7 +1197,7 @@ else
|
||||
endif
|
||||
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
|
||||
ifeq "$(curl_check)" "072200"
|
||||
|
|
Loading…
Reference in a new issue