lighttpd: update to lighttpd 1.4.65 release hash
* update to lighttpd 1.4.65 release hash
* specify lua version w/ -Dlua_version=lua to avoid patching meson.build
Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
(cherry picked from commit db8205e545
)
This commit is contained in:
parent
07f8725492
commit
61ea9bb1a6
2 changed files with 4 additions and 28 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.64
|
||||
PKG_VERSION:=1.4.65
|
||||
PKG_RELEASE:=1
|
||||
# release candidate ~rcX testing; remove for release
|
||||
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.64
|
||||
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.65
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
|
||||
PKG_HASH:=e1489d9fa7496fbf2e071c338b593b2300d38c23f1e5967e52c9ef482e1b0e26
|
||||
PKG_HASH:=bf0fa68a629fbc404023a912b377e70049331d6797bcbb4b3e8df4c3b42328be
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
@ -86,6 +86,7 @@ MESON_ARGS += \
|
|||
-Dwith_libev=false \
|
||||
-Dwith_libunwind=false \
|
||||
-Dwith_lua=$(if $(CONFIG_PACKAGE_lighttpd-mod-magnet),true,false) \
|
||||
-Dlua_version=lua \
|
||||
-Dwith_maxminddb=$(if $(CONFIG_PACKAGE_lighttpd-mod-maxminddb),true,false) \
|
||||
-Dwith_mbedtls=$(if $(CONFIG_PACKAGE_lighttpd-mod-mbedtls),true,false) \
|
||||
-Dwith_mysql=$(if $(CONFIG_PACKAGE_lighttpd-mod-vhostdb_mysql),true,false) \
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From f47d569311d51ec9ab5dad7452b43c1b5a8290b6 Mon Sep 17 00:00:00 2001
|
||||
From: Glenn Strauss <gstrauss@gluelogic.com>
|
||||
Date: Tue, 1 Dec 2020 16:41:58 -0500
|
||||
Subject: [PATCH] [PATCH] [meson] do not search for lua versions
|
||||
|
||||
openwrt net/lighttpd/Makefile declares dependency on liblua, and not on
|
||||
specific lua versions, so have meson.build look for 'lua' and not for
|
||||
specific lua versions.
|
||||
|
||||
Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
|
||||
---
|
||||
src/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -397,7 +397,7 @@ endif
|
||||
liblua = []
|
||||
if get_option('with_lua')
|
||||
found_lua = false
|
||||
- foreach l: ['lua5.4', 'lua-5.4', 'lua5.3', 'lua-5.3', 'lua5.2', 'lua-5.2', 'lua5.1', 'lua-5.1', 'lua']
|
||||
+ foreach l: ['lua']
|
||||
if not(found_lua)
|
||||
liblua = dependency(l, required: false)
|
||||
if (liblua.found())
|
Loading…
Reference in a new issue