https-dns-proxy: add version information to binary
* add patches/020-cmakelists-add-version.patch (thanks @baranyaib90) to add version information to the binary and fix https://github.com/aarond10/https_dns_proxy/issues/149 * modify Makefile to add version information for the binary * rename patches/010-fix-cmakelists.patch for better readability * revert back to service restart in WAN/WAN6 trigger * update test.sh to test both init script and binary versions Signed-off-by: Stan Grishin <stangri@melmac.ca>
This commit is contained in:
parent
8f6831b64b
commit
61ca2f4d16
5 changed files with 56 additions and 5 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=https-dns-proxy
|
PKG_NAME:=https-dns-proxy
|
||||||
PKG_VERSION:=2022-10-15
|
PKG_VERSION:=2022-10-15
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
|
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
|
||||||
|
@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/cmake.mk
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
|
|
||||||
CMAKE_OPTIONS += -DCLANG_TIDY_EXE=
|
CMAKE_OPTIONS += -DCLANG_TIDY_EXE= -DGIT_VERSION=$(PKG_VERSION)-$(PKG_RELEASE)
|
||||||
|
|
||||||
define Package/https-dns-proxy
|
define Package/https-dns-proxy
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
|
|
|
@ -272,7 +272,7 @@ service_triggers() {
|
||||||
wan6="${wan6:-wan6}"
|
wan6="${wan6:-wan6}"
|
||||||
fi
|
fi
|
||||||
for i in "$wan" "$wan6"; do
|
for i in "$wan" "$wan6"; do
|
||||||
[ -n "$i" ] && procd_add_interface_trigger "interface.*" "$i" "/etc/init.d/${packageName}" start
|
[ -n "$i" ] && procd_add_interface_trigger "interface.*" "$i" "/etc/init.d/${packageName}" restart
|
||||||
done
|
done
|
||||||
procd_add_config_trigger "config.change" "$packageName" "/etc/init.d/${packageName}" reload
|
procd_add_config_trigger "config.change" "$packageName" "/etc/init.d/${packageName}" reload
|
||||||
}
|
}
|
||||||
|
|
51
net/https-dns-proxy/patches/020-cmakelists-add-version.patch
Normal file
51
net/https-dns-proxy/patches/020-cmakelists-add-version.patch
Normal file
|
@ -0,0 +1,51 @@
|
||||||
|
From 2ca80486ba6a4e5acbdf0ff581d9754af17fa33b Mon Sep 17 00:00:00 2001
|
||||||
|
From: baranyaib90 <5031516+baranyaib90@users.noreply.github.com>
|
||||||
|
Date: Mon, 24 Oct 2022 22:53:37 +0200
|
||||||
|
Subject: [PATCH] Allow external setting of GIT_VERSION
|
||||||
|
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 34 ++++++++++++++++++----------------
|
||||||
|
1 file changed, 18 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -36,22 +36,24 @@ endif()
|
||||||
|
|
||||||
|
# VERSION
|
||||||
|
|
||||||
|
-find_package(Git)
|
||||||
|
-if(Git_FOUND)
|
||||||
|
- execute_process(
|
||||||
|
- COMMAND "${GIT_EXECUTABLE}" show --date=format:%Y.%m.%d --format=%ad-%h --no-patch
|
||||||
|
- WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
|
||||||
|
- OUTPUT_VARIABLE GIT_VERSION
|
||||||
|
- OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||||
|
- message(STATUS "Version: ${GIT_VERSION}")
|
||||||
|
+if(NOT GIT_VERSION)
|
||||||
|
+ find_package(Git)
|
||||||
|
+ if(Git_FOUND)
|
||||||
|
+ execute_process(
|
||||||
|
+ COMMAND "${GIT_EXECUTABLE}" show --date=format:%Y.%m.%d --format=%ad-%h --no-patch
|
||||||
|
+ WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
|
||||||
|
+ OUTPUT_VARIABLE GIT_VERSION
|
||||||
|
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||||
|
+ message(STATUS "Version: ${GIT_VERSION}")
|
||||||
|
|
||||||
|
- # May not update version in some cases (example: git commit --amend)
|
||||||
|
- set_property(GLOBAL APPEND
|
||||||
|
- PROPERTY CMAKE_CONFIGURE_DEPENDS
|
||||||
|
- "${CMAKE_SOURCE_DIR}/.git/index")
|
||||||
|
-else()
|
||||||
|
- set(GIT_VERSION "UNKNOWN")
|
||||||
|
- message(WARNING "Could not find git command! Version is set to: ${GIT_VERSION}")
|
||||||
|
+ # May not update version in some cases (example: git commit --amend)
|
||||||
|
+ set_property(GLOBAL APPEND
|
||||||
|
+ PROPERTY CMAKE_CONFIGURE_DEPENDS
|
||||||
|
+ "${CMAKE_SOURCE_DIR}/.git/index")
|
||||||
|
+ else()
|
||||||
|
+ set(GIT_VERSION "UNKNOWN")
|
||||||
|
+ message(WARNING "Could not find git command! Version is set to: ${GIT_VERSION}")
|
||||||
|
+ endif()
|
||||||
|
endif()
|
||||||
|
|
||||||
|
# LIBRARY DEPENDENCIES
|
|
@ -1,3 +1,3 @@
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
|
|
||||||
/etc/init.d/"$1" version 2>&1 | grep "$2"
|
/etc/init.d/"$1" version 2>&1 | grep "$2" && "$1" -V 2>&1 | grep "$2"
|
||||||
|
|
Loading…
Reference in a new issue