mosh: use mips16 and remove configure patch
MIPS16 is not needed here.
Removed configure patch and replaced with a configure var.
Removed autoreconf as configure is no longer being patched.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 1ead64489b
)
This commit is contained in:
parent
376d0b76fd
commit
6199615960
2 changed files with 3 additions and 14 deletions
|
@ -19,11 +19,9 @@ PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||||
PKG_LICENSE:=GPL-3.0-or-later
|
PKG_LICENSE:=GPL-3.0-or-later
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_BUILD_DEPENDS:=protobuf/host
|
PKG_BUILD_DEPENDS:=protobuf/host
|
||||||
PKG_USE_MIPS16:=0
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -93,6 +91,9 @@ CONFIGURE_ARGS += \
|
||||||
--disable-hardening \
|
--disable-hardening \
|
||||||
--without-utempter
|
--without-utempter
|
||||||
|
|
||||||
|
CONFIGURE_VARS += \
|
||||||
|
ac_cv_have_decl_ffs=yes
|
||||||
|
|
||||||
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto -std=c++11
|
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto -std=c++11
|
||||||
TARGET_LDFLAGS += -Wl,--gc-sections -lncurses
|
TARGET_LDFLAGS += -Wl,--gc-sections -lncurses
|
||||||
|
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -425,7 +425,8 @@ AC_CHECK_DECL([mach_absolute_time],
|
|
||||||
AC_CHECK_DECLS([__builtin_ctz])
|
|
||||||
|
|
||||||
AC_CHECK_DECLS([ffs], [], [],
|
|
||||||
- [[#include <strings.h>]])
|
|
||||||
+ [[#define _GNU_SOURCE
|
|
||||||
+#include <strings.h>]])
|
|
||||||
|
|
||||||
AC_CHECK_DECLS([be64toh, betoh64, bswap64, __builtin_bswap64], [], [],
|
|
||||||
[[#if defined(HAVE_ENDIAN_H)
|
|
Loading…
Reference in a new issue