python: Replace utime with utimes
Optionally fixes compilation with uClibc-ng. Based on the surrounding code, this looks like an oversight. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
1c412e16a3
commit
608df65a62
2 changed files with 12 additions and 1 deletions
|
@ -12,7 +12,7 @@ include ../python-version.mk
|
|||
|
||||
PKG_NAME:=python
|
||||
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
|
||||
PKG_RELEASE:=8
|
||||
PKG_RELEASE:=9
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
|
|
11
lang/python/python/patches/025-utime.patch
Normal file
11
lang/python/python/patches/025-utime.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Modules/posixmodule.c
|
||||
+++ b/Modules/posixmodule.c
|
||||
@@ -3070,7 +3070,7 @@ done:
|
||||
if (arg == Py_None) {
|
||||
/* optional time values not given */
|
||||
Py_BEGIN_ALLOW_THREADS
|
||||
- res = utime(path, NULL);
|
||||
+ res = utimes(path, NULL);
|
||||
Py_END_ALLOW_THREADS
|
||||
}
|
||||
else if (!PyTuple_Check(arg) || PyTuple_Size(arg) != 2) {
|
Loading…
Reference in a new issue