ttyd: update to 1.6.0
Signed-off-by: Shuanglei Tao <tsl0922@gmail.com>
This commit is contained in:
parent
1f26fad34a
commit
5fc7f40d5b
2 changed files with 4 additions and 14 deletions
|
@ -8,19 +8,18 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ttyd
|
||||
PKG_VERSION:=1.5.2
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tsl0922/ttyd/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=b5b62ec2ce08add0173e6d1dfdd879e55f02f9490043e89f389981a62e87d376
|
||||
PKG_HASH:=d14740bc82be0d0760dd0a3c97acbcbde490412a4edc61edabe46d311b068f83
|
||||
|
||||
PKG_MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=vim/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
@ -29,7 +28,7 @@ define Package/ttyd
|
|||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Command-line tool for sharing terminal over the web
|
||||
DEPENDS:=+libopenssl +libjson-c +libpthread +libwebsockets-full
|
||||
DEPENDS:=+libopenssl +libjson-c +libuv +zlib +libwebsockets-full
|
||||
URL:=https://github.com/tsl0922/ttyd
|
||||
SUBMENU:=Terminal
|
||||
endef
|
||||
|
|
|
@ -1,9 +0,0 @@
|
|||
--- a/src/http.c
|
||||
+++ b/src/http.c
|
||||
@@ -1,5 +1,6 @@
|
||||
#include <string.h>
|
||||
#include <libwebsockets.h>
|
||||
+#include <openssl/ssl.h>
|
||||
|
||||
#include "server.h"
|
||||
#include "html.h"
|
Loading…
Reference in a new issue