nss: update to 3.51.1
also refresh patches Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
This commit is contained in:
parent
b55d2359bc
commit
5fadec5c0e
3 changed files with 12 additions and 18 deletions
|
@ -7,14 +7,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nss
|
PKG_NAME:=nss
|
||||||
PKG_VERSION:=3.51
|
PKG_VERSION:=3.51.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
https://download.cdn.mozilla.net/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src \
|
https://download.cdn.mozilla.net/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src \
|
||||||
https://archive.mozilla.org/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src
|
https://archive.mozilla.org/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src
|
||||||
PKG_HASH:=75348b3b3229362486c57a880db917da1f96ef4eb639dc9cc2ff17d72268459c
|
PKG_HASH:=085c5eaceef040eddea639e2e068e70f0e368f840327a678ef74ae3d6c15ca78
|
||||||
|
|
||||||
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||||
PKG_LICENCE:=MPL-2.0
|
PKG_LICENCE:=MPL-2.0
|
||||||
|
|
|
@ -6,6 +6,9 @@ Origin: Self, rediffed for nss-3.28.
|
||||||
Description: Adds auto-generated nss.pc and nss-config script, and
|
Description: Adds auto-generated nss.pc and nss-config script, and
|
||||||
allows building without nspr in the source tree.
|
allows building without nspr in the source tree.
|
||||||
For 3.40.1, Requires: updated to nspr >= 4.20.
|
For 3.40.1, Requires: updated to nspr >= 4.20.
|
||||||
|
For 3.46.1, Requires: updated to nspr >= 4.21.
|
||||||
|
For 3.48, Requires: updated to nspr >= 4.24.
|
||||||
|
For 3.51.1, Requires: updated to nspr >= 4.25.
|
||||||
|
|
||||||
diff -Naurp nss-3.28-orig/nss/Makefile nss-3.28/nss/Makefile
|
diff -Naurp nss-3.28-orig/nss/Makefile nss-3.28/nss/Makefile
|
||||||
--- nss-3.28-orig/nss/Makefile 2016-12-21 05:56:27.000000000 -0600
|
--- nss-3.28-orig/nss/Makefile 2016-12-21 05:56:27.000000000 -0600
|
||||||
|
@ -232,7 +235,7 @@ diff -Naurp nss-3.28-orig/nss/config/nss.pc.in nss-3.28/nss/config/nss.pc.in
|
||||||
+Name: NSS
|
+Name: NSS
|
||||||
+Description: Network Security Services
|
+Description: Network Security Services
|
||||||
+Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@
|
+Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@
|
||||||
+Requires: nspr >= 4.20
|
+Requires: nspr >= 4.25
|
||||||
+Libs: -L@libdir@ -lnss@NSS_MAJOR_VERSION@ -lnssutil@NSS_MAJOR_VERSION@ -lsmime@NSS_MAJOR_VERSION@ -lssl@NSS_MAJOR_VERSION@ -lsoftokn@NSS_MAJOR_VERSION@
|
+Libs: -L@libdir@ -lnss@NSS_MAJOR_VERSION@ -lnssutil@NSS_MAJOR_VERSION@ -lsmime@NSS_MAJOR_VERSION@ -lssl@NSS_MAJOR_VERSION@ -lsoftokn@NSS_MAJOR_VERSION@
|
||||||
+Cflags: -I${includedir}
|
+Cflags: -I${includedir}
|
||||||
+
|
+
|
||||||
|
|
|
@ -33,15 +33,17 @@
|
||||||
ifeq (,$(filter-out WIN%,$(OS_TARGET)))
|
ifeq (,$(filter-out WIN%,$(OS_TARGET)))
|
||||||
--- a/nss/coreconf/Linux.mk 2019-04-01 10:08:59.129269177 +0300
|
--- a/nss/coreconf/Linux.mk 2019-04-01 10:08:59.129269177 +0300
|
||||||
+++ b/nss/coreconf/Linux.mk 2019-04-01 10:09:15.557782574 +0300
|
+++ b/nss/coreconf/Linux.mk 2019-04-01 10:09:15.557782574 +0300
|
||||||
@@ -143,6 +143,7 @@
|
@@ -144,7 +144,8 @@
|
||||||
DEFINES += -D_REENTRANT
|
DEFINES += -D_REENTRANT
|
||||||
endif
|
endif
|
||||||
|
|
||||||
+ifndef USE_NATIVE
|
+ifndef USE_NATIVE
|
||||||
DSO_CFLAGS = -fPIC
|
-DSO_CFLAGS = -fPIC
|
||||||
|
+DSO_CFLAGS = $(fpic)
|
||||||
DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections
|
DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections
|
||||||
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
|
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
|
||||||
@@ -153,6 +154,7 @@
|
# incorrectly reports undefined references in the libraries we link with, so
|
||||||
|
@@ -154,6 +155,7 @@
|
||||||
ZDEFS_FLAG = -Wl,-z,defs
|
ZDEFS_FLAG = -Wl,-z,defs
|
||||||
DSO_LDOPTS += $(if $(findstring 2.11.90.0.8,$(shell ld -v)),,$(ZDEFS_FLAG))
|
DSO_LDOPTS += $(if $(findstring 2.11.90.0.8,$(shell ld -v)),,$(ZDEFS_FLAG))
|
||||||
LDFLAGS += $(ARCHFLAG) -z noexecstack
|
LDFLAGS += $(ARCHFLAG) -z noexecstack
|
||||||
|
@ -49,20 +51,9 @@
|
||||||
|
|
||||||
# On Maemo, we need to use the -rpath-link flag for even the standard system
|
# On Maemo, we need to use the -rpath-link flag for even the standard system
|
||||||
# library directories.
|
# library directories.
|
||||||
--- a/nss/coreconf/Linux.mk 2019-04-01 23:10:19.091912203 +0300
|
|
||||||
+++ b/nss/coreconf/Linux.mk 2019-04-06 14:07:13.499169075 +0300
|
|
||||||
@@ -144,7 +144,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifndef USE_NATIVE
|
|
||||||
-DSO_CFLAGS = -fPIC
|
|
||||||
+DSO_CFLAGS = $(fpic)
|
|
||||||
DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections
|
|
||||||
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
|
|
||||||
# incorrectly reports undefined references in the libraries we link with, so
|
|
||||||
--- a/nss/coreconf/Linux.mk 2019-04-06 20:25:36.431663894 +0300
|
--- a/nss/coreconf/Linux.mk 2019-04-06 20:25:36.431663894 +0300
|
||||||
+++ b/nss/coreconf/Linux.mk 2019-04-06 20:26:23.397129525 +0300
|
+++ b/nss/coreconf/Linux.mk 2019-04-06 20:26:23.397129525 +0300
|
||||||
@@ -107,11 +107,6 @@
|
@@ -108,11 +108,6 @@
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifdef BUILD_OPT
|
ifdef BUILD_OPT
|
||||||
|
|
Loading…
Reference in a new issue