openvswitch: bump to version 2.11.3
Two patches were backported to fix issue openwrt/packages#12737 0002-compat-Fix-ipv6_dst_lookup-build-error.patch 0003-compat-Backport-ipv6_stub-change.patch One was deleted as it is now part of 2.11.3 0005-datapath-conntrack-fix-include-for-IP6_DEFRAG_CONNTR.patch Other patches refreshed Reported-by: Josef Schlehofer <pepe.schlehofer@gmail.com> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
67755a8ea6
commit
5ed85c0389
11 changed files with 238 additions and 77 deletions
|
@ -1,7 +1,7 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2013 Julius Schulz-Zander <julius@net.t-labs.tu-berlin.de>
|
# Copyright (C) 2013 Julius Schulz-Zander <julius@net.t-labs.tu-berlin.de>
|
||||||
# Copyright (C) 2014-2017 OpenWrt.org
|
# Copyright (C) 2014-2017 OpenWrt.org
|
||||||
# Copyright (C) 2018-2019 Yousong Zhou <yszhou4tech@gmail.com>
|
# Copyright (C) 2018-2020 Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -15,11 +15,11 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||||
# - Check and update kmod dependencies when necessary (runtime module load check in the least)
|
# - Check and update kmod dependencies when necessary (runtime module load check in the least)
|
||||||
#
|
#
|
||||||
PKG_NAME:=openvswitch
|
PKG_NAME:=openvswitch
|
||||||
PKG_VERSION:=2.11.1
|
PKG_VERSION:=2.11.3
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
|
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
|
||||||
PKG_HASH:=c1296ae44a7b176150915e33bc497cc0a7a02caeba84ea43ce9b6a2509d9b5dc
|
PKG_HASH:=4f06935b13627171d133b7312d532e57df3e63d307d6f8c692836dde73d27e15
|
||||||
|
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 2dec526496a62c3aaf849f24ec1b5983a91827a9 Mon Sep 17 00:00:00 2001
|
From 6d90cbb44fd51e1cbb757107d2a86276a66c43df Mon Sep 17 00:00:00 2001
|
||||||
From: Greg Rose <gvrose8192@gmail.com>
|
From: Greg Rose <gvrose8192@gmail.com>
|
||||||
Date: Mon, 6 Jan 2020 13:36:34 -0800
|
Date: Mon, 6 Jan 2020 13:36:34 -0800
|
||||||
Subject: [PATCH] compat: Include confirm_neigh parameter if needed
|
Subject: [PATCH] compat: Include confirm_neigh parameter if needed
|
||||||
|
@ -14,8 +14,8 @@ https://travis-ci.org/gvrose8192/ovs-experimental/builds/633461320
|
||||||
|
|
||||||
Signed-off-by: Greg Rose <gvrose8192@gmail.com>
|
Signed-off-by: Greg Rose <gvrose8192@gmail.com>
|
||||||
Signed-off-by: Simon Horman <simon.horman@netronome.com>
|
Signed-off-by: Simon Horman <simon.horman@netronome.com>
|
||||||
|
(cherry picked from commit 6634cc8aed485967737ef7eda489b9d625a4ca74)
|
||||||
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
(fix acinclude.m4 patch conflict)
|
|
||||||
---
|
---
|
||||||
acinclude.m4 | 2 ++
|
acinclude.m4 | 2 ++
|
||||||
datapath/linux/compat/ip6_gre.c | 4 ++++
|
datapath/linux/compat/ip6_gre.c | 4 ++++
|
||||||
|
@ -23,23 +23,23 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
3 files changed, 11 insertions(+)
|
3 files changed, 11 insertions(+)
|
||||||
|
|
||||||
diff --git a/acinclude.m4 b/acinclude.m4
|
diff --git a/acinclude.m4 b/acinclude.m4
|
||||||
index a581e1ef2..ec1f027e9 100644
|
index f15b1ff67..84098f2a5 100644
|
||||||
--- a/acinclude.m4
|
--- a/acinclude.m4
|
||||||
+++ b/acinclude.m4
|
+++ b/acinclude.m4
|
||||||
@@ -969,6 +969,8 @@ AC_DEFUN([OVS_CHECK_LINUX_COMPAT], [
|
@@ -967,6 +967,8 @@ AC_DEFUN([OVS_CHECK_LINUX_COMPAT], [
|
||||||
OVS_FIND_FIELD_IFELSE([$KSRC/include/net/inet_frag.h], [inet_frags],
|
[OVS_DEFINE([HAVE_NF_CONNTRACK_IN_TAKES_NF_HOOK_STATE])])
|
||||||
[rnd],
|
OVS_GREP_IFELSE([$KSRC/include/net/ipv6_frag.h], [IP6_DEFRAG_CONNTRACK_IN],
|
||||||
[OVS_DEFINE([HAVE_INET_FRAGS_RND])])
|
[OVS_DEFINE([HAVE_IPV6_FRAG_H])])
|
||||||
+ OVS_GREP_IFELSE([$KSRC/include/net/dst_ops.h], [bool confirm_neigh],
|
+ OVS_GREP_IFELSE([$KSRC/include/net/dst_ops.h], [bool confirm_neigh],
|
||||||
+ [OVS_DEFINE([HAVE_DST_OPS_CONFIRM_NEIGH])])
|
+ [OVS_DEFINE([HAVE_DST_OPS_CONFIRM_NEIGH])])
|
||||||
|
|
||||||
if cmp -s datapath/linux/kcompat.h.new \
|
if cmp -s datapath/linux/kcompat.h.new \
|
||||||
datapath/linux/kcompat.h >/dev/null 2>&1; then
|
datapath/linux/kcompat.h >/dev/null 2>&1; then
|
||||||
diff --git a/datapath/linux/compat/ip6_gre.c b/datapath/linux/compat/ip6_gre.c
|
diff --git a/datapath/linux/compat/ip6_gre.c b/datapath/linux/compat/ip6_gre.c
|
||||||
index afff817ec..7fd345309 100644
|
index 2ffdda5e1..89705d778 100644
|
||||||
--- a/datapath/linux/compat/ip6_gre.c
|
--- a/datapath/linux/compat/ip6_gre.c
|
||||||
+++ b/datapath/linux/compat/ip6_gre.c
|
+++ b/datapath/linux/compat/ip6_gre.c
|
||||||
@@ -1089,7 +1089,11 @@ static netdev_tx_t ip6erspan_tunnel_xmit(struct sk_buff *skb,
|
@@ -1196,7 +1196,11 @@ static netdev_tx_t ip6erspan_tunnel_xmit(struct sk_buff *skb,
|
||||||
|
|
||||||
/* TooBig packet may have updated dst->dev's mtu */
|
/* TooBig packet may have updated dst->dev's mtu */
|
||||||
if (!t->parms.collect_md && dst && dst_mtu(dst) > dst->dev->mtu)
|
if (!t->parms.collect_md && dst && dst_mtu(dst) > dst->dev->mtu)
|
||||||
|
@ -52,11 +52,11 @@ index afff817ec..7fd345309 100644
|
||||||
err = ip6_tnl_xmit(skb, dev, dsfield, &fl6, encap_limit, &mtu,
|
err = ip6_tnl_xmit(skb, dev, dsfield, &fl6, encap_limit, &mtu,
|
||||||
NEXTHDR_GRE);
|
NEXTHDR_GRE);
|
||||||
diff --git a/datapath/linux/compat/ip_tunnel.c b/datapath/linux/compat/ip_tunnel.c
|
diff --git a/datapath/linux/compat/ip_tunnel.c b/datapath/linux/compat/ip_tunnel.c
|
||||||
index 7dd57fee9..e7a039358 100644
|
index d16e60fbf..f1c8ba7cd 100644
|
||||||
--- a/datapath/linux/compat/ip_tunnel.c
|
--- a/datapath/linux/compat/ip_tunnel.c
|
||||||
+++ b/datapath/linux/compat/ip_tunnel.c
|
+++ b/datapath/linux/compat/ip_tunnel.c
|
||||||
@@ -267,7 +267,12 @@ static int rpl_tnl_update_pmtu(struct net_device *dev, struct sk_buff *skb,
|
@@ -266,7 +266,12 @@ static int rpl_tnl_update_pmtu(struct net_device *dev, struct sk_buff *skb,
|
||||||
mtu = skb_valid_dst(skb) ? dst_mtu(skb_dst(skb)) : dev->mtu;
|
mtu = skb_dst(skb) ? dst_mtu(skb_dst(skb)) : dev->mtu;
|
||||||
|
|
||||||
if (skb_dst(skb))
|
if (skb_dst(skb))
|
||||||
+#ifndef HAVE_DST_OPS_CONFIRM_NEIGH
|
+#ifndef HAVE_DST_OPS_CONFIRM_NEIGH
|
|
@ -0,0 +1,100 @@
|
||||||
|
From fd3ba6d1ca4b716630b9bc015698f35773a6dd02 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yi-Hung Wei <yihung.wei@gmail.com>
|
||||||
|
Date: Wed, 29 Apr 2020 14:25:50 -0700
|
||||||
|
Subject: [PATCH] compat: Fix ipv6_dst_lookup build error
|
||||||
|
|
||||||
|
The geneve/vxlan compat code base invokes ipv6_dst_lookup() which is
|
||||||
|
recently replaced by ipv6_dst_lookup_flow() in the stable kernel tree.
|
||||||
|
|
||||||
|
This causes travis build failure:
|
||||||
|
* https://travis-ci.org/github/openvswitch/ovs/builds/681084038
|
||||||
|
|
||||||
|
This patch updates the backport logic to invoke the right function.
|
||||||
|
|
||||||
|
Related patch in
|
||||||
|
git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git
|
||||||
|
|
||||||
|
b9f3e457098e ("net: ipv6_stub: use ip6_dst_lookup_flow instead of
|
||||||
|
ip6_dst_lookup")
|
||||||
|
|
||||||
|
Signed-off-by: Yi-Hung Wei <yihung.wei@gmail.com>
|
||||||
|
Signed-off-by: William Tu <u9012063@gmail.com>
|
||||||
|
(cherry picked from commit 5519e384f6a17f564fef4c5eb39e471e16c77235)
|
||||||
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
|
---
|
||||||
|
acinclude.m4 | 3 +++
|
||||||
|
datapath/linux/compat/geneve.c | 11 +++++++----
|
||||||
|
datapath/linux/compat/vxlan.c | 14 ++++++++------
|
||||||
|
3 files changed, 18 insertions(+), 10 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/acinclude.m4 b/acinclude.m4
|
||||||
|
index 84098f2a5..f124caefb 100644
|
||||||
|
--- a/acinclude.m4
|
||||||
|
+++ b/acinclude.m4
|
||||||
|
@@ -508,7 +508,10 @@ AC_DEFUN([OVS_CHECK_LINUX_COMPAT], [
|
||||||
|
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_dst_lookup.*net],
|
||||||
|
[OVS_DEFINE([HAVE_IPV6_DST_LOOKUP_NET])])
|
||||||
|
+ OVS_GREP_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_dst_lookup_flow.*net],
|
||||||
|
+ [OVS_DEFINE([HAVE_IPV6_DST_LOOKUP_FLOW_NET])])
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_stub])
|
||||||
|
+ OVS_GREP_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_dst_lookup_flow])
|
||||||
|
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/linux/err.h], [ERR_CAST])
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/linux/err.h], [IS_ERR_OR_NULL])
|
||||||
|
diff --git a/datapath/linux/compat/geneve.c b/datapath/linux/compat/geneve.c
|
||||||
|
index c044b1489..4bdab6836 100644
|
||||||
|
--- a/datapath/linux/compat/geneve.c
|
||||||
|
+++ b/datapath/linux/compat/geneve.c
|
||||||
|
@@ -962,14 +962,17 @@ static struct dst_entry *geneve_get_v6_dst(struct sk_buff *skb,
|
||||||
|
return dst;
|
||||||
|
}
|
||||||
|
|
||||||
|
-#ifdef HAVE_IPV6_DST_LOOKUP_NET
|
||||||
|
+#if defined(HAVE_IPV6_DST_LOOKUP_FLOW_NET)
|
||||||
|
+ if (ipv6_stub->ipv6_dst_lookup_flow(geneve->net, gs6->sock->sk, &dst,
|
||||||
|
+ fl6)) {
|
||||||
|
+#elif defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
+ if (ipv6_stub->ipv6_dst_lookup_flow(gs6->sock->sk, &dst, fl6)) {
|
||||||
|
+#elif defined(HAVE_IPV6_DST_LOOKUP_NET)
|
||||||
|
if (ipv6_stub->ipv6_dst_lookup(geneve->net, gs6->sock->sk, &dst, fl6)) {
|
||||||
|
-#else
|
||||||
|
-#ifdef HAVE_IPV6_STUB
|
||||||
|
+#elif defined(HAVE_IPV6_STUB)
|
||||||
|
if (ipv6_stub->ipv6_dst_lookup(gs6->sock->sk, &dst, fl6)) {
|
||||||
|
#else
|
||||||
|
if (ip6_dst_lookup(gs6->sock->sk, &dst, fl6)) {
|
||||||
|
-#endif
|
||||||
|
#endif
|
||||||
|
netdev_dbg(dev, "no route to %pI6\n", &fl6->daddr);
|
||||||
|
return ERR_PTR(-ENETUNREACH);
|
||||||
|
diff --git a/datapath/linux/compat/vxlan.c b/datapath/linux/compat/vxlan.c
|
||||||
|
index 23118e8b6..ff10ae6f4 100644
|
||||||
|
--- a/datapath/linux/compat/vxlan.c
|
||||||
|
+++ b/datapath/linux/compat/vxlan.c
|
||||||
|
@@ -990,17 +990,19 @@ static struct dst_entry *vxlan6_get_route(struct vxlan_dev *vxlan,
|
||||||
|
fl6.fl6_dport = dport;
|
||||||
|
fl6.fl6_sport = sport;
|
||||||
|
|
||||||
|
-#ifdef HAVE_IPV6_DST_LOOKUP_NET
|
||||||
|
- err = ipv6_stub->ipv6_dst_lookup(vxlan->net,
|
||||||
|
- sock6->sock->sk,
|
||||||
|
+#if defined(HAVE_IPV6_DST_LOOKUP_FLOW_NET)
|
||||||
|
+ err = ipv6_stub->ipv6_dst_lookup_flow(vxlan->net, sock6->sock->sk,
|
||||||
|
+ &ndst, &fl6);
|
||||||
|
+#elif defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
+ err = ipv6_stub->ipv6_dst_lookup_flow(sock6->sock->sk, &ndst, &fl6);
|
||||||
|
+#elif defined(HAVE_IPV6_DST_LOOKUP_NET)
|
||||||
|
+ err = ipv6_stub->ipv6_dst_lookup(vxlan->net, sock6->sock->sk,
|
||||||
|
&ndst, &fl6);
|
||||||
|
-#else
|
||||||
|
-#ifdef HAVE_IPV6_STUB
|
||||||
|
+#elif defined(HAVE_IPV6_STUB)
|
||||||
|
err = ipv6_stub->ipv6_dst_lookup(vxlan->vn6_sock->sock->sk,
|
||||||
|
&ndst, &fl6);
|
||||||
|
#else
|
||||||
|
err = ip6_dst_lookup(vxlan->vn6_sock->sock->sk, &ndst, &fl6);
|
||||||
|
-#endif
|
||||||
|
#endif
|
||||||
|
if (err < 0)
|
||||||
|
return ERR_PTR(err);
|
|
@ -0,0 +1,108 @@
|
||||||
|
From 558b7fefacda2056bae7a8a573019a8862983e00 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Greg Rose <gvrose8192@gmail.com>
|
||||||
|
Date: Thu, 21 May 2020 14:54:03 -0700
|
||||||
|
Subject: [PATCH] compat: Backport ipv6_stub change
|
||||||
|
|
||||||
|
A patch backported to the Linux stable 4.14 tree and present in the
|
||||||
|
latest stable 4.14.181 kernel breaks ipv6_stub usage.
|
||||||
|
|
||||||
|
The commit is
|
||||||
|
8ab8786f78c3 ("net ipv6_stub: use ip6_dst_lookup_flow instead of ip6_dst_lookup").
|
||||||
|
|
||||||
|
Create the compat layer define to check for it and fixup usage in vxlan
|
||||||
|
and geneve modules.
|
||||||
|
|
||||||
|
Passes Travis here:
|
||||||
|
https://travis-ci.org/github/gvrose8192/ovs-experimental/builds/689798733
|
||||||
|
|
||||||
|
Signed-off-by: Greg Rose <gvrose8192@gmail.com>
|
||||||
|
Signed-off-by: William Tu <u9012063@gmail.com>
|
||||||
|
(cherry picked from commit 33f9c873b19a4993183e0c29a76a114646ca2977)
|
||||||
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
|
---
|
||||||
|
acinclude.m4 | 2 ++
|
||||||
|
datapath/linux/compat/geneve.c | 11 ++++++++++-
|
||||||
|
datapath/linux/compat/vxlan.c | 18 +++++++++++++++++-
|
||||||
|
3 files changed, 29 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/acinclude.m4 b/acinclude.m4
|
||||||
|
index f124caefb..6d8340ce9 100644
|
||||||
|
--- a/acinclude.m4
|
||||||
|
+++ b/acinclude.m4
|
||||||
|
@@ -506,6 +506,8 @@ AC_DEFUN([OVS_CHECK_LINUX_COMPAT], [
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/net/ip6_fib.h], [rt6_get_cookie],
|
||||||
|
[OVS_DEFINE([HAVE_RT6_GET_COOKIE])])
|
||||||
|
|
||||||
|
+ OVS_FIND_FIELD_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_stub],
|
||||||
|
+ [dst_entry])
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_dst_lookup.*net],
|
||||||
|
[OVS_DEFINE([HAVE_IPV6_DST_LOOKUP_NET])])
|
||||||
|
OVS_GREP_IFELSE([$KSRC/include/net/addrconf.h], [ipv6_dst_lookup_flow.*net],
|
||||||
|
diff --git a/datapath/linux/compat/geneve.c b/datapath/linux/compat/geneve.c
|
||||||
|
index 4bdab6836..bf995aa83 100644
|
||||||
|
--- a/datapath/linux/compat/geneve.c
|
||||||
|
+++ b/datapath/linux/compat/geneve.c
|
||||||
|
@@ -962,7 +962,16 @@ static struct dst_entry *geneve_get_v6_dst(struct sk_buff *skb,
|
||||||
|
return dst;
|
||||||
|
}
|
||||||
|
|
||||||
|
-#if defined(HAVE_IPV6_DST_LOOKUP_FLOW_NET)
|
||||||
|
+#if defined(HAVE_IPV6_STUB_WITH_DST_ENTRY) && defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
+#ifdef HAVE_IPV6_DST_LOOKUP_FLOW_NET
|
||||||
|
+ dst = ipv6_stub->ipv6_dst_lookup_flow(geneve->net, gs6->sock->sk, fl6,
|
||||||
|
+ NULL);
|
||||||
|
+#else
|
||||||
|
+ dst = ipv6_stub->ipv6_dst_lookup_flow(gs6->sock->sk, fl6,
|
||||||
|
+ NULL);
|
||||||
|
+#endif
|
||||||
|
+ if (IS_ERR(dst)) {
|
||||||
|
+#elif defined(HAVE_IPV6_DST_LOOKUP_FLOW_NET)
|
||||||
|
if (ipv6_stub->ipv6_dst_lookup_flow(geneve->net, gs6->sock->sk, &dst,
|
||||||
|
fl6)) {
|
||||||
|
#elif defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
diff --git a/datapath/linux/compat/vxlan.c b/datapath/linux/compat/vxlan.c
|
||||||
|
index ff10ae6f4..05ccfb928 100644
|
||||||
|
--- a/datapath/linux/compat/vxlan.c
|
||||||
|
+++ b/datapath/linux/compat/vxlan.c
|
||||||
|
@@ -967,7 +967,10 @@ static struct dst_entry *vxlan6_get_route(struct vxlan_dev *vxlan,
|
||||||
|
bool use_cache = (dst_cache && ip_tunnel_dst_cache_usable(skb, info));
|
||||||
|
struct dst_entry *ndst;
|
||||||
|
struct flowi6 fl6;
|
||||||
|
+#if !defined(HAVE_IPV6_STUB_WITH_DST_ENTRY) || \
|
||||||
|
+ !defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
int err;
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
if (!sock6)
|
||||||
|
return ERR_PTR(-EIO);
|
||||||
|
@@ -990,7 +993,15 @@ static struct dst_entry *vxlan6_get_route(struct vxlan_dev *vxlan,
|
||||||
|
fl6.fl6_dport = dport;
|
||||||
|
fl6.fl6_sport = sport;
|
||||||
|
|
||||||
|
-#if defined(HAVE_IPV6_DST_LOOKUP_FLOW_NET)
|
||||||
|
+#if defined(HAVE_IPV6_STUB_WITH_DST_ENTRY) && defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
+#ifdef HAVE_IPV6_DST_LOOKUP_FLOW_NET
|
||||||
|
+ ndst = ipv6_stub->ipv6_dst_lookup_flow(vxlan->net, sock6->sock->sk,
|
||||||
|
+ &fl6, NULL);
|
||||||
|
+#else
|
||||||
|
+ ndst = ipv6_stub->ipv6_dst_lookup_flow(sock6->sock->sk, &fl6, NULL);
|
||||||
|
+#endif
|
||||||
|
+ if (unlikely(IS_ERR(ndst))) {
|
||||||
|
+#elif defined(HAVE_IPV6_DST_LOOKUP_FLOW_NET)
|
||||||
|
err = ipv6_stub->ipv6_dst_lookup_flow(vxlan->net, sock6->sock->sk,
|
||||||
|
&ndst, &fl6);
|
||||||
|
#elif defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
@@ -1004,8 +1015,13 @@ static struct dst_entry *vxlan6_get_route(struct vxlan_dev *vxlan,
|
||||||
|
#else
|
||||||
|
err = ip6_dst_lookup(vxlan->vn6_sock->sock->sk, &ndst, &fl6);
|
||||||
|
#endif
|
||||||
|
+#if defined(HAVE_IPV6_STUB_WITH_DST_ENTRY) && defined(HAVE_IPV6_DST_LOOKUP_FLOW)
|
||||||
|
+ return ERR_PTR(-ENETUNREACH);
|
||||||
|
+ }
|
||||||
|
+#else
|
||||||
|
if (err < 0)
|
||||||
|
return ERR_PTR(err);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
*saddr = fl6.saddr;
|
||||||
|
if (use_cache)
|
|
@ -1,4 +1,4 @@
|
||||||
From d84109f0b60096ce71cd0537b31b69a7f5ea8756 Mon Sep 17 00:00:00 2001
|
From efca984e5402199ae0bd985b82e31ab2f204a2d2 Mon Sep 17 00:00:00 2001
|
||||||
From: Flavio Leitner <fbl@sysclose.org>
|
From: Flavio Leitner <fbl@sysclose.org>
|
||||||
Date: Sat, 14 Sep 2019 20:17:28 -0300
|
Date: Sat, 14 Sep 2019 20:17:28 -0300
|
||||||
Subject: [PATCH] ovsdb-idlc.in: fix dict change during iteration.
|
Subject: [PATCH] ovsdb-idlc.in: fix dict change during iteration.
|
||||||
|
@ -24,7 +24,7 @@ Signed-off-by: Ben Pfaff <blp@ovn.org>
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
|
diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
|
||||||
index 40fef39edf..22d0a4e22e 100755
|
index 40fef39ed..22d0a4e22 100755
|
||||||
--- a/ovsdb/ovsdb-idlc.in
|
--- a/ovsdb/ovsdb-idlc.in
|
||||||
+++ b/ovsdb/ovsdb-idlc.in
|
+++ b/ovsdb/ovsdb-idlc.in
|
||||||
@@ -176,7 +176,7 @@ def replace_cplusplus_keyword(schema):
|
@@ -176,7 +176,7 @@ def replace_cplusplus_keyword(schema):
|
|
@ -1,46 +0,0 @@
|
||||||
From b89f391203c4420eb454cb321e799a64de809f52 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Yousong Zhou <zhouyousong@yunionyun.com>
|
|
||||||
Date: Fri, 3 May 2019 15:03:24 +0000
|
|
||||||
Subject: [PATCH 5/5] datapath: conntrack: fix include for
|
|
||||||
IP6_DEFRAG_CONNTRACK_IN
|
|
||||||
|
|
||||||
The enum definition is now inside include/net/ipv6_frag.h since upstream commit
|
|
||||||
70b095c ("ipv6: remove dependency of nf_defrag_ipv6 on ipv6 module") which was
|
|
||||||
backported to stable trees (4.9, 4.14, 4.19) only these days.
|
|
||||||
|
|
||||||
The error message
|
|
||||||
|
|
||||||
CC [M] /opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.o
|
|
||||||
/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.c: In function 'handle_fragments':
|
|
||||||
/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.c:554:8: error: variable 'user' has initializer but incomplete type
|
|
||||||
enum ip6_defrag_users user = IP6_DEFRAG_CONNTRACK_IN + zone;
|
|
||||||
^~~~~~~~~~~~~~~~
|
|
||||||
/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.c:554:32: error: 'IP6_DEFRAG_CONNTRACK_IN' undeclared (first use in this function); did you mean 'IP_DEFRAG_CONNTRACK_IN'?
|
|
||||||
enum ip6_defrag_users user = IP6_DEFRAG_CONNTRACK_IN + zone;
|
|
||||||
^~~~~~~~~~~~~~~~~~~~~~~
|
|
||||||
IP_DEFRAG_CONNTRACK_IN
|
|
||||||
/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.c:554:32: note: each undeclared identifier is reported only once for each function it appears in
|
|
||||||
/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.c:554:25: error: storage size of 'user' isn't known
|
|
||||||
enum ip6_defrag_users user = IP6_DEFRAG_CONNTRACK_IN + zone;
|
|
||||||
^~~~
|
|
||||||
/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.c:554:25: warning: unused variable 'user' [-Wunused-variable]
|
|
||||||
scripts/Makefile.build:326: recipe for target '/opt/buildbot/slaves/lede-slave-tah/mipsel_24kc/build/sdk/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/openvswitch-2.11.0/datapath/linux/conntrack.o' failed
|
|
||||||
|
|
||||||
Reference: https://github.com/openwrt/packages/issues/8548#issuecomment-488871090
|
|
||||||
Signed-off-by: Yousong Zhou <zhouyousong@yunionyun.com>
|
|
||||||
---
|
|
||||||
datapath/conntrack.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/datapath/conntrack.c b/datapath/conntrack.c
|
|
||||||
index a7dc9e0c3..69bda5a9c 100644
|
|
||||||
--- a/datapath/conntrack.c
|
|
||||||
+++ b/datapath/conntrack.c
|
|
||||||
@@ -31,6 +31,7 @@
|
|
||||||
#include <net/netfilter/nf_conntrack_seqadj.h>
|
|
||||||
#include <net/netfilter/nf_conntrack_zones.h>
|
|
||||||
#include <net/netfilter/ipv6/nf_defrag_ipv6.h>
|
|
||||||
+#include <net/ipv6_frag.h>
|
|
||||||
|
|
||||||
#ifdef CONFIG_NF_NAT_NEEDED
|
|
||||||
#include <linux/netfilter/nf_nat.h>
|
|
|
@ -1,8 +1,7 @@
|
||||||
From bfcee43923a4bb07954f6648bde1abdcbfa5d95f Mon Sep 17 00:00:00 2001
|
From 64fad2453bc409bf9728a14d8ae630d602e77842 Mon Sep 17 00:00:00 2001
|
||||||
From: Helmut Schaa <helmut.schaa@googlemail.com>
|
From: Helmut Schaa <helmut.schaa@googlemail.com>
|
||||||
Date: Wed, 8 Jan 2014 13:48:49 +0100
|
Date: Wed, 8 Jan 2014 13:48:49 +0100
|
||||||
Subject: [PATCH 1/5] netdev-linux: Let interface flag survive internal port
|
Subject: [PATCH] netdev-linux: Let interface flag survive internal port setup
|
||||||
setup
|
|
||||||
|
|
||||||
Due to a race condition when bringing up an internal port on Linux
|
Due to a race condition when bringing up an internal port on Linux
|
||||||
some interface flags (e.g. IFF_MULTICAST) are falsely reset. This
|
some interface flags (e.g. IFF_MULTICAST) are falsely reset. This
|
||||||
|
@ -18,10 +17,10 @@ Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
|
||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
||||||
index 25d037cb6..ba1427986 100644
|
index 4ab645953..cf23ca753 100644
|
||||||
--- a/lib/netdev-linux.c
|
--- a/lib/netdev-linux.c
|
||||||
+++ b/lib/netdev-linux.c
|
+++ b/lib/netdev-linux.c
|
||||||
@@ -3117,7 +3117,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
@@ -3120,7 +3120,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||||
unsigned int old_flags, new_flags;
|
unsigned int old_flags, new_flags;
|
||||||
int error = 0;
|
int error = 0;
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From e881c50ff537d4b34c10227360589f83d90ce373 Mon Sep 17 00:00:00 2001
|
From 70db9d211bcb68f192aa7b961830cb40bdda73e2 Mon Sep 17 00:00:00 2001
|
||||||
From: Yousong Zhou <zhouyousong@yunionyun.com>
|
From: Yousong Zhou <zhouyousong@yunionyun.com>
|
||||||
Date: Tue, 21 Aug 2018 12:21:05 +0000
|
Date: Tue, 21 Aug 2018 12:21:05 +0000
|
||||||
Subject: [PATCH 2/5] python: separate host/target python for cross-compile
|
Subject: [PATCH] python: separate host/target python for cross-compile
|
||||||
|
|
||||||
At the moment, python-six is a requirement for openvswitch python
|
At the moment, python-six is a requirement for openvswitch python
|
||||||
library on target machine.
|
library on target machine.
|
|
@ -1,7 +1,7 @@
|
||||||
From b65652ff441c4236b51f037a76147331c1ffd5fd Mon Sep 17 00:00:00 2001
|
From 17a9819a0353c93ea83fe86a0a7a67ba9eba530a Mon Sep 17 00:00:00 2001
|
||||||
From: Yousong Zhou <yszhou4tech@gmail.com>
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
Date: Wed, 14 Mar 2018 16:44:13 +0800
|
Date: Wed, 14 Mar 2018 16:44:13 +0800
|
||||||
Subject: [PATCH 3/5] ovs-lib: fix install_dir()
|
Subject: [PATCH] ovs-lib: fix install_dir()
|
||||||
|
|
||||||
The command "install" is not available in OpenWrt by default
|
The command "install" is not available in OpenWrt by default
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/utilities/ovs-lib.in b/utilities/ovs-lib.in
|
diff --git a/utilities/ovs-lib.in b/utilities/ovs-lib.in
|
||||||
index 9a0af2e82..68ab3f250 100644
|
index 5f36b7d44..7ba18b532 100644
|
||||||
--- a/utilities/ovs-lib.in
|
--- a/utilities/ovs-lib.in
|
||||||
+++ b/utilities/ovs-lib.in
|
+++ b/utilities/ovs-lib.in
|
||||||
@@ -159,7 +159,10 @@ install_dir () {
|
@@ -159,7 +159,10 @@ install_dir () {
|
|
@ -1,7 +1,7 @@
|
||||||
From 2f9075aca5f54b8d0c14517c408f162985fb1b18 Mon Sep 17 00:00:00 2001
|
From 613f2bd84623d4f9094697357a7b6bda4611ce30 Mon Sep 17 00:00:00 2001
|
||||||
From: Yousong Zhou <zhouyousong@yunionyun.com>
|
From: Yousong Zhou <zhouyousong@yunionyun.com>
|
||||||
Date: Tue, 21 Aug 2018 13:02:21 +0000
|
Date: Tue, 21 Aug 2018 13:02:21 +0000
|
||||||
Subject: [PATCH 4/5] build: disable building tests
|
Subject: [PATCH] build: disable building tests
|
||||||
|
|
||||||
Signed-off-by: Yousong Zhou <zhouyousong@yunionyun.com>
|
Signed-off-by: Yousong Zhou <zhouyousong@yunionyun.com>
|
||||||
---
|
---
|
|
@ -1,4 +1,4 @@
|
||||||
From ddbe0a362cad22e7171524661fd3d3f83628dd7a Mon Sep 17 00:00:00 2001
|
From c3bd9af7beb085b134235c80c03b96caf4063da4 Mon Sep 17 00:00:00 2001
|
||||||
From: Yousong Zhou <yszhou4tech@gmail.com>
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
Date: Mon, 16 Mar 2020 15:18:16 +0800
|
Date: Mon, 16 Mar 2020 15:18:16 +0800
|
||||||
Subject: [PATCH] datapath: unexport LDFLAGS
|
Subject: [PATCH] datapath: unexport LDFLAGS
|
Loading…
Reference in a new issue