ninja: add new package
This adds a host as well as a target package. ninja.mk is provided to execute ninja. The two patches have been taken from upstream to fix compile issues. Signed-off-by: Andre Heider <a.heider@gmail.com>
This commit is contained in:
parent
f76a90e3da
commit
5ead78be5a
4 changed files with 160 additions and 0 deletions
devel/ninja
77
devel/ninja/Makefile
Normal file
77
devel/ninja/Makefile
Normal file
|
@ -0,0 +1,77 @@
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=ninja
|
||||||
|
PKG_VERSION:=1.9.0
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=https://codeload.github.com/ninja-build/ninja/tar.gz/v$(PKG_VERSION)?
|
||||||
|
PKG_HASH:=5d7ec75828f8d3fd1a0c2f31b5b0cea780cdfe1031359228c428c1a48bfcd5b9
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
|
||||||
|
PKG_LICENSE:=Apache-2.0
|
||||||
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
|
PKG_BUILD_DEPENDS:=ninja/host
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include ./ninja.mk
|
||||||
|
|
||||||
|
CONFIGURE_ARGS:=
|
||||||
|
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
|
||||||
|
CONFIGURE_ARGS+=--verbose
|
||||||
|
endif
|
||||||
|
|
||||||
|
define Host/Configure
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Host/Compile
|
||||||
|
cd $(HOST_BUILD_DIR) && \
|
||||||
|
CXX="$(HOSTCXX)" \
|
||||||
|
CXXFLAGS="$(HOST_CXXFLAGS) $(HOST_CPPFLAGS)" \
|
||||||
|
LDFLAGS="$(HOST_LDFLAGS)" \
|
||||||
|
$(STAGING_DIR_HOST)/bin/$(PYTHON) configure.py --bootstrap $(CONFIGURE_ARGS)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Host/Install
|
||||||
|
$(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/bin
|
||||||
|
$(INSTALL_BIN) $(HOST_BUILD_DIR)/ninja $(STAGING_DIR_HOSTPKG)/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Host/Clean
|
||||||
|
$(call Host/Clean/Default)
|
||||||
|
rm -f $(STAGING_DIR_HOSTPKG)/bin/ninja
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ninja
|
||||||
|
SECTION:=devel
|
||||||
|
CATEGORY:=Development
|
||||||
|
TITLE:=ninja
|
||||||
|
URL:=https://ninja-build.org/
|
||||||
|
DEPENDS:=+libstdcpp
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ninja/description
|
||||||
|
Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ninja/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ninja $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
cd $(PKG_BUILD_DIR) && \
|
||||||
|
CXX="$(TARGET_CXX)" \
|
||||||
|
CXXFLAGS="$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
|
||||||
|
LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
|
||||||
|
$(STAGING_DIR_HOST)/bin/$(PYTHON) configure.py $(CONFIGURE_ARGS)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(call Ninja,-C $(PKG_BUILD_DIR),)
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call HostBuild))
|
||||||
|
$(eval $(call BuildPackage,ninja))
|
16
devel/ninja/ninja.mk
Normal file
16
devel/ninja/ninja.mk
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
# To execute ninja from you package's Makefile:
|
||||||
|
#
|
||||||
|
# include ../../devel/ninja/ninja.mk
|
||||||
|
#
|
||||||
|
# define Build/Compile
|
||||||
|
# $(call Ninja,-C $(MY_NINJA_BUILD_DIR),$(MY_NINJA_ENV_VARS))
|
||||||
|
# endef
|
||||||
|
|
||||||
|
NINJA_ARGS:=$(filter -j%,$(filter-out -j,$(MAKEFLAGS)))
|
||||||
|
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
|
||||||
|
NINJA_ARGS+=-v
|
||||||
|
endif
|
||||||
|
|
||||||
|
define Ninja
|
||||||
|
$(2) $(STAGING_DIR_HOSTPKG)/bin/ninja $(NINJA_ARGS) $(1)
|
||||||
|
endef
|
37
devel/ninja/patches/010-musl.patch
Normal file
37
devel/ninja/patches/010-musl.patch
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
From 567815df38a2ff54ad7478a90bd75c91e434236a Mon Sep 17 00:00:00 2001
|
||||||
|
From: makepost <makepost@firemail.cc>
|
||||||
|
Date: Mon, 24 Dec 2018 03:13:16 +0200
|
||||||
|
Subject: [PATCH] Use st_mtim if st_mtime is macro, fix #1510
|
||||||
|
|
||||||
|
In POSIX.1-2008, sys_stat has a st_mtim member and a st_mtime backward
|
||||||
|
compatibility macro. Should help avoid hardcoding platform detection.
|
||||||
|
---
|
||||||
|
src/disk_interface.cc | 14 ++++----------
|
||||||
|
1 file changed, 4 insertions(+), 10 deletions(-)
|
||||||
|
|
||||||
|
--- a/src/disk_interface.cc
|
||||||
|
+++ b/src/disk_interface.cc
|
||||||
|
@@ -202,19 +202,13 @@ TimeStamp RealDiskInterface::Stat(const
|
||||||
|
// that it doesn't exist.
|
||||||
|
if (st.st_mtime == 0)
|
||||||
|
return 1;
|
||||||
|
-#if defined(__APPLE__) && !defined(_POSIX_C_SOURCE)
|
||||||
|
+#if defined(_AIX)
|
||||||
|
+ return (int64_t)st.st_mtime * 1000000000LL + st.st_mtime_n;
|
||||||
|
+#elif defined(__APPLE__)
|
||||||
|
return ((int64_t)st.st_mtimespec.tv_sec * 1000000000LL +
|
||||||
|
st.st_mtimespec.tv_nsec);
|
||||||
|
-#elif (_POSIX_C_SOURCE >= 200809L || _XOPEN_SOURCE >= 700 || defined(_BSD_SOURCE) || defined(_SVID_SOURCE) || \
|
||||||
|
- defined(__BIONIC__) || (defined (__SVR4) && defined (__sun)) || defined(__FreeBSD__))
|
||||||
|
- // For glibc, see "Timestamp files" in the Notes of http://www.kernel.org/doc/man-pages/online/pages/man2/stat.2.html
|
||||||
|
- // newlib, uClibc and musl follow the kernel (or Cygwin) headers and define the right macro values above.
|
||||||
|
- // For bsd, see https://github.com/freebsd/freebsd/blob/master/sys/sys/stat.h and similar
|
||||||
|
- // For bionic, C and POSIX API is always enabled.
|
||||||
|
- // For solaris, see https://docs.oracle.com/cd/E88353_01/html/E37841/stat-2.html.
|
||||||
|
+#elif defined(st_mtime) // A macro, so we're likely on modern POSIX.
|
||||||
|
return (int64_t)st.st_mtim.tv_sec * 1000000000LL + st.st_mtim.tv_nsec;
|
||||||
|
-#elif defined(_AIX)
|
||||||
|
- return (int64_t)st.st_mtime * 1000000000LL + st.st_mtime_n;
|
||||||
|
#else
|
||||||
|
return (int64_t)st.st_mtime * 1000000000LL + st.st_mtimensec;
|
||||||
|
#endif
|
30
devel/ninja/patches/020-uclibc.patch
Normal file
30
devel/ninja/patches/020-uclibc.patch
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
From 76abf78aac8c56606fb52ea874873d790b9044da Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Pawel Hajdan, Jr" <phajdan.jr@chromium.org>
|
||||||
|
Date: Mon, 2 Jan 2017 10:42:35 +0000
|
||||||
|
Subject: [PATCH] Fix build with uclibc
|
||||||
|
|
||||||
|
Resolves #985
|
||||||
|
|
||||||
|
This is based on musl implementation,
|
||||||
|
http://git.musl-libc.org/cgit/musl/commit/?id=20cbd607759038dca57f84ef7e7b5d44a3088574
|
||||||
|
(thanks to jbergstroem@ for reference)
|
||||||
|
---
|
||||||
|
src/util.cc | 7 +++++++
|
||||||
|
1 file changed, 7 insertions(+)
|
||||||
|
|
||||||
|
--- a/src/util.cc
|
||||||
|
+++ b/src/util.cc
|
||||||
|
@@ -572,6 +572,13 @@ double GetLoadAverage() {
|
||||||
|
return -0.0f;
|
||||||
|
return 1.0 / (1 << SI_LOAD_SHIFT) * si.loads[0];
|
||||||
|
}
|
||||||
|
+#elif defined(__UCLIBC__)
|
||||||
|
+double GetLoadAverage() {
|
||||||
|
+ struct sysinfo si;
|
||||||
|
+ if (sysinfo(&si) != 0)
|
||||||
|
+ return -0.0f;
|
||||||
|
+ return 1.0 / (1 << SI_LOAD_SHIFT) * si.loads[0];
|
||||||
|
+}
|
||||||
|
#else
|
||||||
|
double GetLoadAverage() {
|
||||||
|
double loadavg[3] = { 0.0f, 0.0f, 0.0f };
|
Loading…
Reference in a new issue