netdata: Update to version 1.17.1
Patch 002 - Force Python3 is no longer applying, let's try to throw it away to see if it is still necessary Patch 003 - Was backported from the master branch and it was included in Netdata version 1.17.0 Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
This commit is contained in:
parent
8ed2d22de3
commit
5e898166e7
3 changed files with 3 additions and 102 deletions
|
@ -8,8 +8,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=netdata
|
||||
PKG_VERSION:=1.16.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.17.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>, Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
|
@ -18,7 +18,7 @@ PKG_CPE_ID:=cpe:/a:my-netdata:netdata
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/netdata/netdata/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=94492108a6e24e8b39c011ae35ff6f50a848d816af396fdf2b44655cecd78672
|
||||
PKG_HASH:=032f9001e2b7f774989a200519feeafa3a4d9b7c9e8fb0cfa43e68a8da6ad1bf
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- a/collectors/python.d.plugin/python.d.plugin.in
|
||||
+++ b/collectors/python.d.plugin/python.d.plugin.in
|
||||
@@ -1,10 +1,4 @@
|
||||
-#!/usr/bin/env bash
|
||||
-'''':;
|
||||
-if [[ "$OSTYPE" == "darwin"* ]]; then
|
||||
- export OBJC_DISABLE_INITIALIZE_FORK_SAFETY=YES
|
||||
-fi
|
||||
-exec "$(command -v python || command -v python3 || command -v python2 ||
|
||||
-echo "ERROR python IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@" # '''
|
||||
+#!/usr/bin/python3
|
||||
|
||||
# -*- coding: utf-8 -*-
|
||||
# Description:
|
|
@ -1,85 +0,0 @@
|
|||
From 893bfc98d3f33d02ce6d6a3a48fb02c964156fb5 Mon Sep 17 00:00:00 2001
|
||||
From: Markos Fountoulakis <markos.fountoulakis.senior@gmail.com>
|
||||
Date: Wed, 14 Aug 2019 11:55:50 +0300
|
||||
Subject: [PATCH] Stop configure.ac from linking against dbengine and https
|
||||
libraries when dbengine or https are disabled
|
||||
|
||||
---
|
||||
configure.ac | 28 +++++++++++++---------------
|
||||
1 file changed, 13 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 56e484cc2c..8dbdcaa17f 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -280,9 +280,6 @@ AC_CHECK_LIB(
|
||||
[UV_LIBS="-luv"]
|
||||
)
|
||||
|
||||
-OPTIONAL_UV_CFLAGS="${UV_CFLAGS}"
|
||||
-OPTIONAL_UV_LIBS="${UV_LIBS}"
|
||||
-
|
||||
|
||||
# -----------------------------------------------------------------------------
|
||||
# lz4 Extremely Fast Compression algorithm
|
||||
@@ -293,9 +290,6 @@ AC_CHECK_LIB(
|
||||
[LZ4_LIBS="-llz4"]
|
||||
)
|
||||
|
||||
-OPTIONAL_LZ4_CFLAGS="${LZ4_CFLAGS}"
|
||||
-OPTIONAL_LZ4_LIBS="${LZ4_LIBS}"
|
||||
-
|
||||
|
||||
# -----------------------------------------------------------------------------
|
||||
# Judy General purpose dynamic array
|
||||
@@ -306,9 +300,6 @@ AC_CHECK_LIB(
|
||||
[JUDY_LIBS="-lJudy"]
|
||||
)
|
||||
|
||||
-OPTIONAL_JUDY_CFLAGS="${JUDY_CFLAGS}"
|
||||
-OPTIONAL_JUDY_LIBS="${JUDY_LIBS}"
|
||||
-
|
||||
|
||||
# -----------------------------------------------------------------------------
|
||||
# zlib
|
||||
@@ -356,9 +347,6 @@ AC_CHECK_LIB(
|
||||
[SSL_LIBS="-lcrypto -lssl"]
|
||||
)
|
||||
|
||||
-OPTIONAL_SSL_CFLAGS="${SSL_CFLAGS}"
|
||||
-OPTIONAL_SSL_LIBS="${SSL_LIBS}"
|
||||
-
|
||||
# -----------------------------------------------------------------------------
|
||||
# JSON-C library
|
||||
|
||||
@@ -391,6 +379,14 @@ AC_MSG_CHECKING([if netdata dbengine should be used])
|
||||
if test "${enable_dbengine}" != "no" -a "${UV_LIBS}" -a "${LZ4_LIBS}" -a "${JUDY_LIBS}" -a "${SSL_LIBS}"; then
|
||||
enable_dbengine="yes"
|
||||
AC_DEFINE([ENABLE_DBENGINE], [1], [netdata dbengine usability])
|
||||
+ OPTIONAL_UV_CFLAGS="${UV_CFLAGS}"
|
||||
+ OPTIONAL_UV_LIBS="${UV_LIBS}"
|
||||
+ OPTIONAL_LZ4_CFLAGS="${LZ4_CFLAGS}"
|
||||
+ OPTIONAL_LZ4_LIBS="${LZ4_LIBS}"
|
||||
+ OPTIONAL_JUDY_CFLAGS="${JUDY_CFLAGS}"
|
||||
+ OPTIONAL_JUDY_LIBS="${JUDY_LIBS}"
|
||||
+ OPTIONAL_SSL_CFLAGS="${SSL_CFLAGS}"
|
||||
+ OPTIONAL_SSL_LIBS="${SSL_LIBS}"
|
||||
else
|
||||
enable_dbengine="no"
|
||||
fi
|
||||
@@ -399,10 +395,12 @@ AM_CONDITIONAL([ENABLE_DBENGINE], [test "${enable_dbengine}" = "yes"])
|
||||
|
||||
AC_MSG_CHECKING([if netdata https should be used])
|
||||
if test "${enable_https}" != "no" -a "${SSL_LIBS}"; then
|
||||
- enable_https="yes"
|
||||
- AC_DEFINE([ENABLE_HTTPS], [1], [netdata HTTPS usability])
|
||||
+ enable_https="yes"
|
||||
+ AC_DEFINE([ENABLE_HTTPS], [1], [netdata HTTPS usability])
|
||||
+ OPTIONAL_SSL_CFLAGS="${SSL_CFLAGS}"
|
||||
+ OPTIONAL_SSL_LIBS="${SSL_LIBS}"
|
||||
else
|
||||
- enable_https="no"
|
||||
+ enable_https="no"
|
||||
fi
|
||||
AC_MSG_RESULT([${enable_https}])
|
||||
AM_CONDITIONAL([ENABLE_HTTPS], [test "${enable_https}" = "yes"])
|
Loading…
Reference in a new issue