node: bump to v16.17.0
Notable Changes:
Experimental command-line argument parser API
Experimental ESM Loader Hooks API
Experimental test runner
Improved interoperability of the Web Crypto API
Dependency updates:
Updated Corepack to 0.12.1
Updated ICU to 71.1
Updated npm to 8.15.0
Updated Undici to 5.8.0
Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
(cherry picked from commit 841b38f37a
)
This commit is contained in:
parent
4c311180da
commit
5dc5c79663
8 changed files with 17 additions and 17 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=node
|
||||
PKG_VERSION:=v16.16.0
|
||||
PKG_VERSION:=v16.17.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
||||
PKG_HASH:=145151eff3b2aa5ebe73384009c52271a83740ae687a93c98c628cd7d52736eb
|
||||
PKG_HASH:=1d28c285685e446985921bc963565ca9c0c5f4fda9755e489c06808ea9795645
|
||||
|
||||
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/internal/modules/cjs/loader.js
|
||||
+++ b/lib/internal/modules/cjs/loader.js
|
||||
@@ -1240,7 +1240,8 @@ Module._initPaths = function() {
|
||||
@@ -1261,7 +1261,8 @@ Module._initPaths = function() {
|
||||
path.resolve(process.execPath, '..') :
|
||||
path.resolve(process.execPath, '..', '..');
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/tools/gyp/pylib/gyp/generator/make.py
|
||||
+++ b/tools/gyp/pylib/gyp/generator/make.py
|
||||
@@ -179,7 +179,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
|
||||
@@ -181,7 +181,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
|
||||
|
||||
LINK_COMMANDS_MAC = """\
|
||||
quiet_cmd_alink = LIBTOOL-STATIC $@
|
||||
|
|
|
@ -118,7 +118,7 @@
|
|||
"%s: LD_INPUTS := %s"
|
||||
--- a/tools/gyp/pylib/gyp/generator/make.py
|
||||
+++ b/tools/gyp/pylib/gyp/generator/make.py
|
||||
@@ -154,6 +154,32 @@ cmd_alink_thin = rm -f $@ && $(AR.$(TOOL
|
||||
@@ -156,6 +156,32 @@ cmd_alink_thin = rm -f $@ && $(AR.$(TOOL
|
||||
quiet_cmd_link = LINK($(TOOLSET)) $@
|
||||
cmd_link = $(LINK.$(TOOLSET)) -o $@ $(GYP_LDFLAGS) $(LDFLAGS.$(TOOLSET)) -Wl,--start-group $(LD_INPUTS) $(LIBS) -Wl,--end-group
|
||||
|
||||
|
@ -151,7 +151,7 @@
|
|||
# We support two kinds of shared objects (.so):
|
||||
# 1) shared_library, which is just bundling together many dependent libraries
|
||||
# into a link line.
|
||||
@@ -198,6 +224,32 @@ cmd_alink = rm -f $@ && $(AR.$(TOOLSET))
|
||||
@@ -200,6 +226,32 @@ cmd_alink = rm -f $@ && $(AR.$(TOOLSET))
|
||||
quiet_cmd_alink_thin = AR($(TOOLSET)) $@
|
||||
cmd_alink_thin = rm -f $@ && $(AR.$(TOOLSET)) crsT $@ $(filter %.o,$^)
|
||||
|
||||
|
@ -184,7 +184,7 @@
|
|||
# Due to circular dependencies between libraries :(, we wrap the
|
||||
# special "figure out circular dependencies" flags around the entire
|
||||
# input list during linking.
|
||||
@@ -1768,21 +1820,35 @@ $(obj).$(TOOLSET)/$(TARGET)/%%.o: $(obj)
|
||||
@@ -1809,21 +1861,35 @@ $(obj).$(TOOLSET)/$(TARGET)/%%.o: $(obj)
|
||||
self.flavor not in ("mac", "openbsd", "netbsd", "win")
|
||||
and not self.is_standalone_static_library
|
||||
):
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/deps/v8/src/compiler/backend/mips/code-generator-mips.cc
|
||||
+++ b/deps/v8/src/compiler/backend/mips/code-generator-mips.cc
|
||||
@@ -4230,7 +4230,7 @@ void CodeGenerator::AssembleReturn(Instr
|
||||
@@ -4103,7 +4103,7 @@ void CodeGenerator::AssembleReturn(Instr
|
||||
} else if (FLAG_debug_code) {
|
||||
__ Assert(eq, AbortReason::kUnexpectedAdditionalPopValue,
|
||||
g.ToRegister(additional_pop_count),
|
||||
|
|
|
@ -34,7 +34,7 @@
|
|||
'<@(icu_src_genccode)',
|
||||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -1363,6 +1363,7 @@
|
||||
@@ -1365,6 +1365,7 @@
|
||||
{
|
||||
'target_name': 'bytecode_builtins_list_generator',
|
||||
'type': 'executable',
|
||||
|
@ -42,7 +42,7 @@
|
|||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1387,6 +1388,8 @@
|
||||
@@ -1389,6 +1390,8 @@
|
||||
{
|
||||
'target_name': 'mksnapshot',
|
||||
'type': 'executable',
|
||||
|
@ -51,7 +51,7 @@
|
|||
'dependencies': [
|
||||
'v8_base_without_compiler',
|
||||
'v8_compiler_for_mksnapshot',
|
||||
@@ -1408,6 +1411,7 @@
|
||||
@@ -1410,6 +1413,7 @@
|
||||
{
|
||||
'target_name': 'torque',
|
||||
'type': 'executable',
|
||||
|
@ -59,7 +59,7 @@
|
|||
'dependencies': [
|
||||
'torque_base',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -1446,6 +1450,7 @@
|
||||
@@ -1448,6 +1452,7 @@
|
||||
{
|
||||
'target_name': 'torque-language-server',
|
||||
'type': 'executable',
|
||||
|
@ -67,7 +67,7 @@
|
|||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1473,6 +1478,8 @@
|
||||
@@ -1475,6 +1480,8 @@
|
||||
{
|
||||
'target_name': 'gen-regexp-special-case',
|
||||
'type': 'executable',
|
||||
|
|
|
@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
|
|||
//
|
||||
// Permission is hereby granted, free of charge, to any person obtaining a
|
||||
// copy of this software and associated documentation files (the
|
||||
@@ -1059,13 +1060,6 @@ function lookupAndConnect(self, options)
|
||||
@@ -1118,13 +1119,6 @@ function lookupAndConnect(self, options)
|
||||
hints: options.hints || 0
|
||||
};
|
||||
|
||||
|
|
|
@ -59,7 +59,7 @@
|
|||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -1343,6 +1349,7 @@
|
||||
@@ -1345,6 +1351,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
|
@ -67,7 +67,7 @@
|
|||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1691,6 +1698,7 @@
|
||||
@@ -1693,6 +1700,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
|
@ -75,7 +75,7 @@
|
|||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1871,15 +1879,19 @@
|
||||
@@ -1873,15 +1881,19 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
|
|
Loading…
Reference in a new issue