Merge pull request #5484 from neheb/patch-1
transmission: Update to 2.93 + fixes
This commit is contained in:
commit
5d0688284b
5 changed files with 13 additions and 68 deletions
|
@ -8,22 +8,22 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=transmission
|
||||
PKG_VERSION:=2.92+git
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=2.93
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/transmission/transmission.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=5b29fe15561d40c40cbee635446df6b33e18d2c2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=f99982ae68564da9bf6ad4407285aff2e29508e4fd801ff56f86a8b3dae01819
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/transmission/transmission-releases/raw/master
|
||||
PKG_HASH:=8815920e0a4499bcdadbbe89a4115092dab42ce5199f71ff9a926cfd12b9b90b
|
||||
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/transmission/template
|
||||
|
@ -32,7 +32,6 @@ define Package/transmission/template
|
|||
CATEGORY:=Network
|
||||
TITLE:=BitTorrent client
|
||||
URL:=http://www.transmissionbt.com
|
||||
MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/transmission-daemon/Default
|
||||
|
|
|
@ -49,6 +49,7 @@ config transmission
|
|||
option rpc_authentication_required false
|
||||
option rpc_bind_address '0.0.0.0'
|
||||
option rpc_enabled true
|
||||
option rpc_host_whitelist_enabled false
|
||||
option rpc_password ''
|
||||
option rpc_port 9091
|
||||
option rpc_url '/transmission/'
|
||||
|
|
|
@ -95,7 +95,7 @@ transmission() {
|
|||
speed_limit_down speed_limit_down_enabled speed_limit_up \
|
||||
speed_limit_up_enabled start_added_torrents trash_original_torrent_files \
|
||||
umask upload_slots_per_torrent utp_enabled scrape_paused_torrents \
|
||||
watch_dir_enabled
|
||||
watch_dir_enabled rpc_host_whitelist_enabled
|
||||
|
||||
append_params_quotes "$cfg" \
|
||||
blocklist_url bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir \
|
||||
|
@ -113,6 +113,7 @@ transmission() {
|
|||
procd_set_param command $cmdline
|
||||
procd_set_param respawn retry=60
|
||||
procd_set_param user "$user"
|
||||
procd_set_param group "$user"
|
||||
procd_set_param nice "$nice"
|
||||
if test -z "$USE";then
|
||||
procd_set_param limits core="0 0"
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -42,8 +42,8 @@ set(TR_NAME ${PROJECT_NAME})
|
||||
# "Z" for unsupported trunk builds,
|
||||
# "0" for stable, supported releases
|
||||
# these should be the only two lines you need to change
|
||||
-set(TR_USER_AGENT_PREFIX "2.92+")
|
||||
-set(TR_PEER_ID_PREFIX "-TR292Z-")
|
||||
+set(TR_USER_AGENT_PREFIX "2.92")
|
||||
+set(TR_PEER_ID_PREFIX "-TR2920-")
|
||||
|
||||
string(REGEX MATCH "^([0-9]+)\\.([0-9]+).*" TR_VERSION "${TR_USER_AGENT_PREFIX}")
|
||||
set(TR_VERSION_MAJOR "${CMAKE_MATCH_1}")
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3,8 +3,8 @@ dnl STATUS: "X" for prerelease beta buil
|
||||
dnl "Z" for unsupported trunk builds,
|
||||
dnl "0" for stable, supported releases
|
||||
dnl these should be the only two lines you need to change
|
||||
-m4_define([user_agent_prefix],[2.92+])
|
||||
-m4_define([peer_id_prefix],[-TR292Z-])
|
||||
+m4_define([user_agent_prefix],[2.92])
|
||||
+m4_define([peer_id_prefix],[-TR2920-])
|
||||
|
||||
AC_INIT([transmission],[user_agent_prefix],[https://trac.transmissionbt.com/newticket])
|
||||
AC_SUBST(USERAGENT_PREFIX,[user_agent_prefix])
|
|
@ -1,30 +0,0 @@
|
|||
diff --git a/daemon/daemon.c b/daemon/daemon.c
|
||||
index 7b2a3b425..5b19d105a 100644
|
||||
--- a/daemon/daemon.c
|
||||
+++ b/daemon/daemon.c
|
||||
@@ -715,12 +715,7 @@ static int daemon_start(void* raw_arg, bool foreground)
|
||||
}
|
||||
|
||||
#ifdef HAVE_SYSLOG
|
||||
-
|
||||
- if (!foreground)
|
||||
- {
|
||||
- openlog(MY_NAME, LOG_CONS | LOG_PID, LOG_DAEMON);
|
||||
- }
|
||||
-
|
||||
+ openlog(MY_NAME, LOG_CONS | LOG_PID, LOG_DAEMON);
|
||||
#endif
|
||||
|
||||
/* Create new timer event to report daemon status */
|
||||
@@ -772,11 +767,8 @@ cleanup:
|
||||
/* shutdown */
|
||||
#ifdef HAVE_SYSLOG
|
||||
|
||||
- if (!foreground)
|
||||
- {
|
||||
syslog(LOG_INFO, "%s", "Closing session");
|
||||
closelog();
|
||||
- }
|
||||
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue