Merge pull request #12668 from neheb/oplc
open-plc-utils: fix compilation with GCC10
This commit is contained in:
commit
5c92509b0c
2 changed files with 12 additions and 1 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=open-plc-utils
|
PKG_NAME:=open-plc-utils
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
|
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
|
||||||
|
|
11
utils/open-plc-utils/patches/010-gcc10.patch
Normal file
11
utils/open-plc-utils/patches/010-gcc10.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/plc/plc.h
|
||||||
|
+++ b/plc/plc.h
|
||||||
|
@@ -498,7 +498,7 @@ struct __packed plcproperty
|
||||||
|
uint8_t DATA_BUFFER [128];
|
||||||
|
}
|
||||||
|
|
||||||
|
-plcproperty;
|
||||||
|
+extern plcproperty;
|
||||||
|
|
||||||
|
#ifndef __GNUC__
|
||||||
|
#pragma pack (pop)
|
Loading…
Reference in a new issue