Merge pull request #12668 from neheb/oplc

open-plc-utils: fix compilation with GCC10
This commit is contained in:
Michael Heimpold 2020-07-02 07:47:18 +02:00 committed by GitHub
commit 5c92509b0c
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 12 additions and 1 deletions

View file

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git

View file

@ -0,0 +1,11 @@
--- a/plc/plc.h
+++ b/plc/plc.h
@@ -498,7 +498,7 @@ struct __packed plcproperty
uint8_t DATA_BUFFER [128];
}
-plcproperty;
+extern plcproperty;
#ifndef __GNUC__
#pragma pack (pop)