Revert "openthread-br: new package"
The PR to add openthread-br in master isn't merged yet, as it has draft
status. This was merged prematurely. Revert.
This reverts commit 27dd30aadb
.
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
This commit is contained in:
parent
71e8e63a34
commit
5c1e589739
4 changed files with 0 additions and 240 deletions
|
@ -1,80 +0,0 @@
|
|||
# SPDX-FileCopyrightText: 2022 Stijn Tintel <stijn@linux-ipv6.be>
|
||||
# SPDX-License-Identifier: GPL-2.0-only
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openthread-br
|
||||
PKG_SOURCE_DATE:=2022-08-12
|
||||
PKG_SOURCE_VERSION:=7a1bb4df86f9ce0fc26a16b8a5adaa16bf8d1e99
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL=https://github.com/openthread/ot-br-posix.git
|
||||
PKG_MIRROR_HASH:=3c517762943b192c50be34cac218133253a16596f711520b552b724822770c6e
|
||||
|
||||
#PKG_BUILD_DIR:=$(BUILD_DIR)/ot-br-posix-thread-br-certified-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
||||
define Package/openthread-br
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=OpenThread Border Router
|
||||
DEPENDS:= \
|
||||
+libavahi-client \
|
||||
+libblobmsg-json \
|
||||
+libjson-c \
|
||||
+libncurses \
|
||||
+libreadline \
|
||||
+libstdcpp \
|
||||
+libubox \
|
||||
+libubus
|
||||
endef
|
||||
|
||||
define Package/openthread-br/description
|
||||
A Thread border router for POSIX-based platforms.
|
||||
endef
|
||||
|
||||
define Package/openthread-br/conffiles
|
||||
/etc/config/openthread
|
||||
endef
|
||||
|
||||
CMAKE_OPTIONS += \
|
||||
-DOT_BACKBONE_ROUTER:BOOL=ON \
|
||||
-DOT_BORDER_ROUTER:BOOL=ON \
|
||||
-DOT_BORDER_ROUTING:BOOL=ON \
|
||||
-DOT_BORDER_ROUTING_NAT64:BOOL=ON \
|
||||
-DOT_CHANNEL_MANAGER:BOOL=ON \
|
||||
-DOT_CHANNEL_MONITOR:BOOL=ON \
|
||||
-DOT_COMMISSIONER:BOOL=ON \
|
||||
-DOT_SERVICE:BOOL=ON \
|
||||
-DOT_TREL:BOOL=ON \
|
||||
-DOTBR_OPENWRT:BOOL=ON
|
||||
|
||||
define Package/openthread-br/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/etc/config $(1)/etc/init.d \
|
||||
$(1)/usr/lib/lua/luci/controller/admin \
|
||||
$(1)/usr/lib/lua/luci/view/admin_thread $(1)/usr/sbin \
|
||||
$(1)/www/luci-static/resources
|
||||
$(INSTALL_CONF) ./files/openthread.conf $(1)/etc/config/openthread
|
||||
$(INSTALL_BIN) ./files/otbr-agent.init $(1)/etc/init.d/otbr-agent
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/src/openwrt/controller/thread.lua \
|
||||
$(1)/usr/lib/lua/luci/controller/admin
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/src/openwrt/view/admin_thread/* \
|
||||
$(1)/usr/lib/lua/luci/view/admin_thread
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/src/openwrt/handle_error.js \
|
||||
$(1)/www/luci-static/resources
|
||||
endef
|
||||
|
||||
|
||||
$(eval $(call BuildPackage,openthread-br))
|
|
@ -1,8 +0,0 @@
|
|||
config otbr 'agent'
|
||||
option enabled '0'
|
||||
option auto_attach '0'
|
||||
option iface_lan 'eth0'
|
||||
option iface_wpan 'wpan0'
|
||||
list radio_url 'spinel+hdlc+uart:///dev/ttyACM0'
|
||||
list radio_url 'trel://eth0'
|
||||
option verbose '0'
|
|
@ -1,47 +0,0 @@
|
|||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=99
|
||||
USE_PROCD=1
|
||||
PROG=/usr/sbin/otbr-agent
|
||||
|
||||
validate_section_otbr_agent() {
|
||||
logger -t otbr-agent "validating agent section"
|
||||
uci_load_validate openthread otbr "$1" "$2" \
|
||||
'auto_attach:bool:0' \
|
||||
'enabled:bool:0' \
|
||||
'iface_lan:string' \
|
||||
'iface_wpan:string' \
|
||||
'radio_url:list(string)' \
|
||||
'verbose:bool:0'
|
||||
}
|
||||
|
||||
start_otbr_agent() {
|
||||
[ "$2" -eq 0 ] || {
|
||||
echo "validation failed"
|
||||
return 1
|
||||
}
|
||||
|
||||
[ "$enabled" -eq 1 ] || return 0
|
||||
|
||||
|
||||
procd_open_instance
|
||||
|
||||
procd_set_param command $PROG
|
||||
|
||||
procd_append_param command --auto-attach="$auto_attach"
|
||||
[ "$iface_lan" ] && procd_append_param command -B "$iface_lan"
|
||||
[ "$iface_wpan" ] && procd_append_param command -I "$iface_wpan"
|
||||
[ "$verbose" -eq 1 ] && procd_append_param command -v
|
||||
|
||||
for url in $radio_url; do
|
||||
procd_append_param command "$url"
|
||||
done
|
||||
|
||||
procd_set_param respawn
|
||||
|
||||
procd_close_instance
|
||||
}
|
||||
|
||||
start_service() {
|
||||
validate_section_otbr_agent agent start_otbr_agent
|
||||
}
|
|
@ -1,105 +0,0 @@
|
|||
--- a/src/openwrt/view/admin_thread/thread_add.htm
|
||||
+++ b/src/openwrt/view/admin_thread/thread_add.htm
|
||||
@@ -64,7 +64,6 @@
|
||||
</div>
|
||||
</form>
|
||||
|
||||
-<%+footer%>
|
||||
<script type="text/javascript" src="/luci-static/resources/handle_error.js"></script>
|
||||
<script type="text/javascript">//<![CDATA[
|
||||
handle_error(GetURLParameter('error'));
|
||||
@@ -78,3 +77,4 @@
|
||||
}
|
||||
}
|
||||
//]]></script>
|
||||
+<%+footer%>
|
||||
--- a/src/openwrt/view/admin_thread/thread_join.htm
|
||||
+++ b/src/openwrt/view/admin_thread/thread_join.htm
|
||||
@@ -42,7 +42,6 @@
|
||||
</div>
|
||||
</form>
|
||||
|
||||
-<%+footer%>
|
||||
<script type="text/javascript">//<![CDATA[
|
||||
function validateForm()
|
||||
{
|
||||
@@ -54,3 +53,4 @@
|
||||
}
|
||||
}
|
||||
//]]></script>
|
||||
+<%+footer%>
|
||||
--- a/src/openwrt/view/admin_thread/thread_overview.htm
|
||||
+++ b/src/openwrt/view/admin_thread/thread_overview.htm
|
||||
@@ -76,7 +76,6 @@
|
||||
<div class="td"><em><%:Collecting data...%></em></div>
|
||||
</div>
|
||||
</div>
|
||||
-<%+footer%>
|
||||
|
||||
<script type="text/javascript" src="/luci-static/resources/handle_error.js"></script>
|
||||
<script type="text/javascript">//<![CDATA[
|
||||
@@ -202,3 +201,4 @@
|
||||
}
|
||||
});
|
||||
//]]></script>
|
||||
+<%+footer%>
|
||||
--- a/src/openwrt/view/admin_thread/thread_setting.htm
|
||||
+++ b/src/openwrt/view/admin_thread/thread_setting.htm
|
||||
@@ -73,16 +73,16 @@
|
||||
<span>
|
||||
<strong>PAN ID: </strong>
|
||||
<%=threadget("panid").PanId%>
|
||||
- <br>
|
||||
+ <br />
|
||||
<strong>Extended PAN ID: </strong>
|
||||
<%=threadget("extpanid").ExtPanId%>
|
||||
- <br>
|
||||
+ <br />
|
||||
<strong>State: </strong>
|
||||
<%=state%>
|
||||
- <br>
|
||||
+ <br />
|
||||
<strong>Channel: </strong>
|
||||
<%=threadget("channel").Channel%>
|
||||
- <span>
|
||||
+ </span>
|
||||
</span>
|
||||
</div>
|
||||
</div>
|
||||
@@ -103,7 +103,7 @@
|
||||
<label class="cbi-value-title" style="margin-right:5%;">Protocol</label>
|
||||
<div class="cbi-value-field">
|
||||
<select style="width:30%;" id="protocol" name="protocol">
|
||||
- <option value>unmanaged</option>
|
||||
+ <option value="unmanaged">unmanaged</option>
|
||||
</select>
|
||||
</div>
|
||||
</div>
|
||||
@@ -269,7 +269,6 @@
|
||||
|
||||
</form>
|
||||
|
||||
-<%+footer%>
|
||||
|
||||
<script type="text/javascript" src="/luci-static/resources/handle_error.js"></script>
|
||||
<script type="text/javascript">//<![CDATA[
|
||||
@@ -397,3 +396,4 @@
|
||||
}
|
||||
}
|
||||
//]]></script>
|
||||
+<%+footer%>
|
||||
--- a/src/openwrt/view/admin_thread/thread_view.htm
|
||||
+++ b/src/openwrt/view/admin_thread/thread_view.htm
|
||||
@@ -114,7 +114,6 @@
|
||||
<input class="cbi-button cbi-button-add" type="submit" value="<%:Add%>" />
|
||||
</form>
|
||||
</div>
|
||||
-<%+footer%>
|
||||
|
||||
<script src='http://d3js.org/d3.v4.min.js'></script>
|
||||
<script type="text/javascript" src="/luci-static/resources/handle_error.js"></script>
|
||||
@@ -388,3 +387,4 @@
|
||||
else return "Pending";
|
||||
}
|
||||
//]]></script>
|
||||
+<%+footer%>
|
Loading…
Reference in a new issue