ffmpeg: update to 5.0.1
Bump to latest upstream version, patches automatically rebased. Removed upstreamed: 060-configure-link-to-libatomic-when-its-present.patch Tested using: ffmpeg -f lavfi -i testsrc=duration=10:size=1280x720:rate=30 testsrc.mpg Resulting mpg was good. Build system: x86_64 Build-tested: bcm2711/RPi4B Run-tested: bcm2711/RPi4B Signed-off-by: John Audia <graysky@archlinux.us>
This commit is contained in:
parent
d6960886bd
commit
5b85e7466c
2 changed files with 2 additions and 49 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ffmpeg
|
||||
PKG_VERSION:=5.0
|
||||
PKG_VERSION:=5.0.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://ffmpeg.org/releases/
|
||||
PKG_HASH:=51e919f7d205062c0fd4fae6243a84850391115104ccf1efc451733bc0ac7298
|
||||
PKG_HASH:=ef2efae259ce80a240de48ec85ecb062cecca26e4352ffb3fda562c21a93007b
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Ian Leonard <antonlacon@gmail.com>
|
||||
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3791,20 +3791,20 @@ cws2fws_extralibs="zlib_extralibs"
|
||||
|
||||
# libraries, in any order
|
||||
avcodec_deps="avutil"
|
||||
-avcodec_suggest="libm"
|
||||
+avcodec_suggest="libm stdatomic"
|
||||
avdevice_deps="avformat avcodec avutil"
|
||||
-avdevice_suggest="libm"
|
||||
+avdevice_suggest="libm stdatomic"
|
||||
avfilter_deps="avutil"
|
||||
-avfilter_suggest="libm"
|
||||
+avfilter_suggest="libm stdatomic"
|
||||
avformat_deps="avcodec avutil"
|
||||
-avformat_suggest="libm network zlib"
|
||||
-avutil_suggest="clock_gettime ffnvcodec libm libdrm libmfx opencl user32 vaapi vulkan videotoolbox corefoundation corevideo coremedia bcrypt"
|
||||
+avformat_suggest="libm network zlib stdatomic"
|
||||
+avutil_suggest="clock_gettime ffnvcodec libm libdrm libmfx opencl user32 vaapi vulkan videotoolbox corefoundation corevideo coremedia bcrypt stdatomic"
|
||||
postproc_deps="avutil gpl"
|
||||
-postproc_suggest="libm"
|
||||
+postproc_suggest="libm stdatomic"
|
||||
swresample_deps="avutil"
|
||||
-swresample_suggest="libm libsoxr"
|
||||
+swresample_suggest="libm libsoxr stdatomic"
|
||||
swscale_deps="avutil"
|
||||
-swscale_suggest="libm"
|
||||
+swscale_suggest="libm stdatomic"
|
||||
|
||||
avcodec_extralibs="pthreads_extralibs iconv_extralibs dxva2_extralibs"
|
||||
avfilter_extralibs="pthreads_extralibs"
|
||||
@@ -6321,7 +6321,14 @@ check_headers asm/types.h
|
||||
# it seems there are versions of clang in some distros that try to use the
|
||||
# gcc headers, which explodes for stdatomic
|
||||
# so we also check that atomics actually work here
|
||||
-check_builtin stdatomic stdatomic.h "atomic_int foo, bar = ATOMIC_VAR_INIT(-1); atomic_store(&foo, 0); foo += bar"
|
||||
+#
|
||||
+# some configurations also require linking to libatomic, so try
|
||||
+# both with -latomic and without
|
||||
+for LATOMIC in "-latomic" ""; do
|
||||
+ check_builtin stdatomic stdatomic.h \
|
||||
+ "atomic_int foo, bar = ATOMIC_VAR_INIT(-1); atomic_store(&foo, 0); foo += bar" \
|
||||
+ $LATOMIC && eval stdatomic_extralibs="\$LATOMIC" && break
|
||||
+done
|
||||
|
||||
check_lib advapi32 "windows.h" RegCloseKey -ladvapi32
|
||||
check_lib bcrypt "windows.h bcrypt.h" BCryptGenRandom -lbcrypt &&
|
Loading…
Reference in a new issue