libjpeg: update to 9a
Signed-off-by: Steven Barth <steven@midlink.org>
This commit is contained in:
parent
575b95d771
commit
5adeb3dfd6
4 changed files with 5 additions and 1938 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=jpeg
|
||||
PKG_VERSION:=6b
|
||||
PKG_VERSION:=9a
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)src.v$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/libjpeg
|
||||
PKG_MD5SUM:=dbd5f3b47ed13132f04c685d608a7547
|
||||
PKG_SOURCE_URL:=http://www.ijg.org/files
|
||||
PKG_MD5SUM:=3353992aecaee1805ef4109aadd433e7
|
||||
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
||||
PKG_LICENSE:=IJG
|
||||
|
@ -55,26 +55,15 @@ HOST_CONFIGURE_ARGS += \
|
|||
--enable-shared \
|
||||
--enable-static \
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
rm -f ltconfig ltmain.sh libtool; \
|
||||
ln -s `which true` ltconfig; \
|
||||
ln -s $(STAGING_DIR)/host/bin/libtool libtool; \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/{include,lib,bin,man/man1}
|
||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||
LIBTOOL="./libtool --tag=CC" \
|
||||
prefix="$(PKG_INSTALL_DIR)/usr" \
|
||||
exec_prefix="$(PKG_INSTALL_DIR)/usr" \
|
||||
all
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
prefix="$(PKG_INSTALL_DIR)/usr" \
|
||||
exec_prefix="$(PKG_INSTALL_DIR)/usr" \
|
||||
install install-headers install-lib
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/makefile.cfg
|
||||
+++ b/makefile.cfg
|
||||
@@ -168,7 +168,7 @@ libjpeg.a: @A2K_DEPS@ $(LIBOBJECTS)
|
||||
|
||||
# with libtool:
|
||||
libjpeg.la: @A2K_DEPS@ $(LIBOBJECTS)
|
||||
- $(LIBTOOL) --mode=link $(CC) -o libjpeg.la $(LIBOBJECTS) \
|
||||
+ $(LIBTOOL) --mode=link "$(CC)" -o libjpeg.la $(LIBOBJECTS) \
|
||||
-rpath $(libdir) -version-info $(JPEG_LIB_VERSION)
|
||||
|
||||
# sample programs:
|
File diff suppressed because it is too large
Load diff
|
@ -1,15 +0,0 @@
|
|||
--- a/jdmarker.c
|
||||
+++ b/jdmarker.c
|
||||
@@ -342,6 +342,12 @@ get_sos (j_decompress_ptr cinfo)
|
||||
|
||||
TRACEMS3(cinfo, 1, JTRC_SOS_COMPONENT, cc,
|
||||
compptr->dc_tbl_no, compptr->ac_tbl_no);
|
||||
+
|
||||
+ /* This CSi (cc) should differ from the previous CSi */
|
||||
+ for (ci = 0; ci < i; ci++) {
|
||||
+ if (cinfo->cur_comp_info[ci] == compptr)
|
||||
+ ERREXIT1(cinfo, JERR_BAD_COMPONENT_ID, cc);
|
||||
+ }
|
||||
}
|
||||
|
||||
/* Collect the additional scan parameters Ss, Se, Ah/Al. */
|
Loading…
Reference in a new issue