bwm-ng: fix building with gcc-security enabled
Signed-off-by: Julen Landa Alustiza <julen@zokormazo.info>
This commit is contained in:
parent
530772b9d0
commit
5aae478e24
2 changed files with 13 additions and 2 deletions
|
@ -1,12 +1,12 @@
|
|||
#
|
||||
# Copyright (C) 2014 OpenWrt.org
|
||||
# Copyright (C) 2014-2015 OpenWrt.org
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bwm-ng
|
||||
PKG_VERSION:=0.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.gropp.org/bwm-ng
|
||||
|
|
11
net/bwm-ng/patches/0001-fix-gcc-security-build.patch
Normal file
11
net/bwm-ng/patches/0001-fix-gcc-security-build.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/output.c
|
||||
+++ b/src/output.c
|
||||
@@ -234,7 +234,7 @@ int print_header(int option) {
|
||||
if (output_method==PLAIN_OUT && ansi_output) printf("\033[1;2H");
|
||||
printf("bwm-ng v" VERSION " (delay %2.3fs); ",(float)delay/1000);
|
||||
if (output_method==PLAIN_OUT) printf("press 'ctrl-c' to end this%s",(ansi_output ? "\033[2;2H" : "")); else printf("input: ");
|
||||
- printf(input2str());
|
||||
+ printf("%s\n",input2str());
|
||||
printf("%s\n",show_all_if2str());
|
||||
if (output_method==PLAIN_OUT) {
|
||||
if (ansi_output)
|
Loading…
Reference in a new issue