mpd: update to v0.21.16 and build with meson
One patch was dropped (probably not required anymore). Old options have been dropped and new ones added. The order is as found in meson_options.txt. mpd-mini and mpd-full retained their feature sets. Signed-off-by: Andre Heider <a.heider@gmail.com>
This commit is contained in:
parent
0469c0715b
commit
5aaa1e7da4
3 changed files with 103 additions and 100 deletions
|
@ -6,19 +6,17 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mpd
|
||||
PKG_VERSION:=0.20.23
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=0.21.16
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.20/
|
||||
PKG_HASH:=503e5f9f237290f568ff7956ab2f9aed563594bf749f19b8fe994fb21434afea
|
||||
PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.21/
|
||||
PKG_HASH:=30cf1bddf7d7388487276745ad3515f134e07f0c57f9f97cb2b5d3befd4a4d92
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_IPV6 \
|
||||
|
||||
|
@ -27,6 +25,7 @@ PKG_USE_MIPS16:=0
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
define Package/mpd/Default
|
||||
SECTION:=sound
|
||||
|
@ -34,7 +33,7 @@ define Package/mpd/Default
|
|||
TITLE:=Music Player Daemon
|
||||
URL:=http://www.musicpd.org/
|
||||
DEPENDS:= +zlib +libcurl +libpthread +libmpdclient +libstdcpp $(ICONV_DEPENDS) \
|
||||
+AUDIO_SUPPORT:alsa-lib +boost +boost-container +libexpat +libflac
|
||||
+AUDIO_SUPPORT:alsa-lib +boost +libexpat +libflac
|
||||
endef
|
||||
|
||||
define Package/mpd/Default/description
|
||||
|
@ -47,7 +46,7 @@ endef
|
|||
define Package/mpd-full
|
||||
$(call Package/mpd/Default)
|
||||
TITLE+= (full)
|
||||
DEPENDS+= +libffmpeg +libid3tag +libmms +libupnp +libshout +pulseaudio-daemon +yajl
|
||||
DEPENDS+= +libffmpeg +libid3tag +libvorbis +libmms +libupnp +libshout +pulseaudio-daemon +yajl
|
||||
PROVIDES:=mpd
|
||||
VARIANT:=full
|
||||
endef
|
||||
|
@ -100,90 +99,110 @@ endef
|
|||
|
||||
EXTRA_LDFLAGS += $(if $(ICONV_FULL),-liconv,-Wl,--whole-archive -liconv -Wl,--no-whole-archive) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/pulseaudio
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
$(call autoconf_bool,CONFIG_IPV6,ipv6) \
|
||||
--disable-debug \
|
||||
--disable-documentation \
|
||||
--disable-test \
|
||||
--disable-aac \
|
||||
--disable-adplug \
|
||||
--disable-ao \
|
||||
--disable-audiofile \
|
||||
--disable-bzip2 \
|
||||
--disable-cdio-paranoia \
|
||||
--disable-fluidsynth \
|
||||
--disable-wildmidi \
|
||||
--disable-gme \
|
||||
--enable-inotify \
|
||||
--disable-icu \
|
||||
--enable-iconv \
|
||||
--disable-iso9660 \
|
||||
--disable-jack \
|
||||
--disable-roar \
|
||||
--disable-libwrap \
|
||||
--disable-lsr \
|
||||
--disable-mad \
|
||||
--disable-mikmod \
|
||||
--disable-modplug \
|
||||
--disable-mpc \
|
||||
--disable-nfs \
|
||||
--disable-openal \
|
||||
--disable-opus \
|
||||
--disable-sidplay \
|
||||
--disable-smbclient \
|
||||
--disable-sndfile \
|
||||
--disable-solaris-output \
|
||||
--disable-sqlite \
|
||||
--disable-systemd-daemon \
|
||||
--disable-lame-encoder \
|
||||
--disable-twolame-encoder \
|
||||
--disable-shine-encoder \
|
||||
--disable-vorbis-encoder \
|
||||
--enable-wave-encoder \
|
||||
--disable-wavpack \
|
||||
--enable-webdav \
|
||||
--disable-zzip \
|
||||
--with-zeroconf=no \
|
||||
--disable-soxr \
|
||||
--enable-curl \
|
||||
--enable-httpd-output \
|
||||
$(call autoconf_bool,CONFIG_AUDIO_SUPPORT,alsa) \
|
||||
--enable-tcp \
|
||||
--disable-sndio \
|
||||
--disable-haiku
|
||||
MESON_ARGS += \
|
||||
-Ddocumentation=false \
|
||||
-Dtest=false \
|
||||
-Dsyslog=enabled \
|
||||
-Dinotify=true \
|
||||
-Ddaemon=false \
|
||||
-Dsystemd=disabled \
|
||||
-Dtcp=true \
|
||||
-Dipv6=$(if $(CONFIG_IPV6),enabled,disabled) \
|
||||
-Dlocal_socket=true \
|
||||
-Ddsd=false \
|
||||
-Ddatabase=true \
|
||||
-Dlibmpdclient=enabled \
|
||||
-Dneighbor=false \
|
||||
-Dudisks=disabled \
|
||||
-Dwebdav=enabled \
|
||||
-Dcue=true \
|
||||
-Dcdio_paranoia=disabled \
|
||||
-Dcurl=enabled \
|
||||
-Dnfs=disabled \
|
||||
-Dsmbclient=disabled \
|
||||
-Dqobuz=disabled \
|
||||
-Dtidal=disabled \
|
||||
-Dbzip2=disabled \
|
||||
-Diso9660=disabled \
|
||||
-Dzzip=disabled \
|
||||
-Dchromaprint=disabled \
|
||||
-Dadplug=disabled \
|
||||
-Daudiofile=disabled \
|
||||
-Dfaad=disabled \
|
||||
-Dflac=enabled \
|
||||
-Dfluidsynth=disabled \
|
||||
-Dgme=disabled \
|
||||
-Dmad=disabled \
|
||||
-Dmikmod=disabled \
|
||||
-Dmodplug=disabled \
|
||||
-Dmpcdec=disabled \
|
||||
-Dopus=disabled \
|
||||
-Dsidplay=disabled \
|
||||
-Dsndfile=disabled \
|
||||
-Dwavpack=disabled \
|
||||
-Dwildmidi=disabled \
|
||||
-Dvorbisenc=disabled \
|
||||
-Dlame=disabled \
|
||||
-Dtwolame=disabled \
|
||||
-Dshine=disabled \
|
||||
-Dwave_encoder=true \
|
||||
-Dlibsamplerate=disabled \
|
||||
-Dsoxr=disabled \
|
||||
-Dalsa=$(if CONFIG_AUDIO_SUPPORT,enabled,disabled) \
|
||||
-Dao=disabled \
|
||||
-Dhttpd=true \
|
||||
-Djack=disabled \
|
||||
-Dopenal=disabled \
|
||||
-Doss=disabled \
|
||||
-Dsndio=disabled \
|
||||
-Dsolaris_output=disabled \
|
||||
-Ddbus=disabled \
|
||||
-Dexpat=enabled \
|
||||
-Dicu=disabled \
|
||||
-Diconv=enabled \
|
||||
-Dpcre=disabled \
|
||||
-Dsqlite=disabled \
|
||||
-Dzlib=enabled \
|
||||
-Dzeroconf=disabled
|
||||
|
||||
|
||||
ifeq ($(BUILD_VARIANT),full)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-upnp \
|
||||
--enable-ffmpeg \
|
||||
--enable-id3 \
|
||||
--enable-mms \
|
||||
--disable-mpg123 \
|
||||
--enable-pipe-output \
|
||||
--enable-recorder-output \
|
||||
--enable-shout \
|
||||
--enable-pulse \
|
||||
--disable-vorbis \
|
||||
--enable-soundcloud
|
||||
MESON_ARGS += \
|
||||
-Dupnp=enabled \
|
||||
-Dmms=enabled \
|
||||
-Dsoundcloud=enabled \
|
||||
-Did3tag=enabled \
|
||||
-Dffmpeg=enabled \
|
||||
-Dmpg123=disabled \
|
||||
-Dtremor=disabled \
|
||||
-Dvorbis=enabled \
|
||||
-Dfifo=true \
|
||||
-Dpipe=true \
|
||||
-Dpulse=enabled \
|
||||
-Drecorder=true \
|
||||
-Dshout=enabled \
|
||||
-Dyajl=enabled
|
||||
endif
|
||||
|
||||
ifeq ($(BUILD_VARIANT),mini)
|
||||
|
||||
# oggflac is not compatible with tremor
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-upnp \
|
||||
--disable-fifo \
|
||||
--disable-ffmpeg \
|
||||
--disable-id3 \
|
||||
--disable-mms \
|
||||
--disable-shout \
|
||||
--disable-soundcloud \
|
||||
--disable-pulse \
|
||||
--enable-vorbis \
|
||||
--with-tremor=yes \
|
||||
--disable-recorder-output
|
||||
MESON_ARGS += \
|
||||
-Dupnp=disabled \
|
||||
-Dmms=disabled \
|
||||
-Dsoundcloud=disabled \
|
||||
-Did3tag=disabled \
|
||||
-Dffmpeg=disabled \
|
||||
-Dmpg123=enabled \
|
||||
-Dtremor=enabled \
|
||||
-Dvorbis=disabled \
|
||||
-Dfifo=false \
|
||||
-Dpipe=false \
|
||||
-Dpulse=disabled \
|
||||
-Drecorder=false \
|
||||
-Dshout=disabled \
|
||||
-Dyajl=disabled
|
||||
endif
|
||||
|
||||
define Package/mpd/install
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/decoder/plugins/FfmpegDecoderPlugin.cxx
|
||||
+++ b/src/decoder/plugins/FfmpegDecoderPlugin.cxx
|
||||
@@ -937,6 +937,7 @@ static const char *const ffmpeg_mime_typ
|
||||
@@ -775,6 +775,7 @@ static const char *const ffmpeg_mime_typ
|
||||
"audio/qcelp",
|
||||
"audio/vorbis",
|
||||
"audio/vorbis+ogg",
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- a/src/decoder/plugins/FfmpegDecoderPlugin.cxx
|
||||
+++ b/src/decoder/plugins/FfmpegDecoderPlugin.cxx
|
||||
@@ -478,6 +478,13 @@ ffmpeg_probe(DecoderClient *client, Inpu
|
||||
|
||||
unsigned char buffer[BUFFER_SIZE];
|
||||
size_t nbytes = decoder_read(client, is, buffer, BUFFER_SIZE);
|
||||
+
|
||||
+ if ((nbytes > 0) && (nbytes < 1024))
|
||||
+ {
|
||||
+ // Gobble some more data if header is small
|
||||
+ nbytes += decoder_read(client, is, buffer + nbytes, BUFFER_SIZE - nbytes);
|
||||
+ }
|
||||
+
|
||||
if (nbytes <= PADDING)
|
||||
return nullptr;
|
||||
|
Loading…
Reference in a new issue