spice: fix building against arc770-uclibc toolchain
Supersedes openwrt/packages#10873 Ref: https://github.com/openwrt/packages/pull/10873 Reported-by: Rosen Penev <rosenp@gmail.com> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
8a64d1ff5d
commit
5a25cf86ea
3 changed files with 28 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=spice
|
||||
PKG_VERSION:=0.14.2
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://www.spice-space.org/download/releases/spice-server
|
||||
PKG_HASH:=b203b3882e06f4c7249a3150d90c84e1a90490d41ead255a3d2cede46f4a29a7
|
||||
|
@ -55,5 +55,6 @@ CONFIGURE_ARGS += \
|
|||
--disable-smartcard \
|
||||
--disable-statistics \
|
||||
--without-sasl \
|
||||
--disable-silent-rules \
|
||||
|
||||
$(eval $(call BuildPackage,libspice-server))
|
||||
|
|
14
libs/spice/patches/0003-disable-building-tests.patch
Normal file
14
libs/spice/patches/0003-disable-building-tests.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
Tests build can fail for arc700 for the following causes
|
||||
|
||||
- Missing -stack-protector-all argument when building test progs
|
||||
- Missing linker flag -lgmodule-2.0 -lffi
|
||||
|
||||
--- a/server/Makefile.am.orig 2019-12-25 18:31:59.133981942 +0800
|
||||
+++ b/server/Makefile.am 2019-12-25 18:32:06.308976585 +0800
|
||||
@@ -1,5 +1,5 @@
|
||||
NULL =
|
||||
-SUBDIRS = . tests
|
||||
+SUBDIRS = .
|
||||
|
||||
check-valgrind:
|
||||
$(MAKE) -C tests check-valgrind
|
12
libs/spice/patches/0004-fix-building-tools.patch
Normal file
12
libs/spice/patches/0004-fix-building-tools.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
Tools build can fail because -stack-protector-all is missing
|
||||
|
||||
--- a/tools/Makefile.am.orig 2019-12-25 18:51:48.947959673 +0800
|
||||
+++ b/tools/Makefile.am 2019-12-25 18:51:56.165952726 +0800
|
||||
@@ -8,6 +8,7 @@ AM_CPPFLAGS = \
|
||||
|
||||
AM_LDFLAGS = \
|
||||
$(LIBRT) \
|
||||
+ $(WARN_LDFLAGS) \
|
||||
$(NULL)
|
||||
|
||||
noinst_PROGRAMS = \
|
Loading…
Reference in a new issue