sshfs: update to 3.7.0
Simplified Makefile as a result of meson transition. Fixed license information. Updated URL. Added patch to fix linking issue. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
6e65081643
commit
59d5308ba9
2 changed files with 24 additions and 27 deletions
|
@ -8,50 +8,36 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sshfs
|
||||
PKG_VERSION:=2.10
|
||||
PKG_VERSION:=3.7.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/libfuse/sshfs/releases/download/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_HASH:=70845dde2d70606aa207db5edfe878e266f9c193f1956dd10ba1b7e9a3c8d101
|
||||
PKG_HASH:=6e7e86831f3066b356e7f16e22f1b8a8f177fda05146f6a5eb821c2fd0541c34
|
||||
|
||||
PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
define Package/sshfs
|
||||
TITLE:=SSHFS
|
||||
DEPENDS:=+libfuse +fuse-utils +glib2 +libpthread
|
||||
DEPENDS:=+fuse3-utils +glib2 +libpthread
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=Filesystem
|
||||
URL:=http://fuse.sourceforge.net/
|
||||
URL:=https://github.com/libfuse/sshfs
|
||||
endef
|
||||
|
||||
define Package/sshfs/description
|
||||
Mount remote system over sftp.
|
||||
endef
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
SSHFS_CFLAGS=" \
|
||||
-D_FILE_OFFSET_BITS=64 \
|
||||
-I$(STAGING_DIR)/usr/include/glib-2.0 \
|
||||
-I$(STAGING_DIR)/usr/lib/glib-2.0/include \
|
||||
-I$(STAGING_DIR)/usr/include/fuse" \
|
||||
SSHFS_LIBS=" \
|
||||
-lglib-2.0 -liconv $(if $(INTL_FULL),-lintl) -lfuse -pthread -lgthread-2.0 \
|
||||
-L$(STAGING_DIR)/usr/lib"
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/sshfs/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sshfs $(1)/usr/bin/
|
||||
|
|
11
net/sshfs/patches/010-fuse3.patch
Normal file
11
net/sshfs/patches/010-fuse3.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -51,7 +51,7 @@ sshfs_deps = [ dependency('fuse3', version: '>= 3.1.0'),
|
||||
executable('sshfs', sshfs_sources,
|
||||
include_directories: include_dirs,
|
||||
dependencies: sshfs_deps,
|
||||
- c_args: ['-DFUSE_USE_VERSION=31'],
|
||||
+ c_args: ['-DFUSE_USE_VERSION=30'],
|
||||
install: true,
|
||||
install_dir: get_option('bindir'))
|
||||
|
Loading…
Reference in a new issue