samba: update to 4.14.7
* update to 4.14.7 * remove domain if fqdn was set * allow disabling wsdd2 in menuconfig Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
This commit is contained in:
parent
ca591b551b
commit
5939310841
4 changed files with 20 additions and 7 deletions
|
@ -1,3 +1,16 @@
|
|||
config SAMBA4_SERVER_WSDD2
|
||||
bool "WSD support"
|
||||
depends on PACKAGE_samba4-server
|
||||
select PACKAGE_wsdd2
|
||||
help
|
||||
selects: wsdd2 (daemon)
|
||||
|
||||
WSD/LLMNR Discovery/Name Service Daemon
|
||||
WSD (Web Services for Devices) replaces the functionality of NetBIOS and is provided by the wsdd2 package (selected by default).
|
||||
Note: As of Windows 10 Fall Creators Update (1709) NetBIOS isn't supported unless the old SMB1 feature is reinstalled (not recommended).
|
||||
Network shares can be directly accessed via network paths '\\hostname\sharename' and mounted via 'map network drive' without NetBIOS or WSD.
|
||||
default y
|
||||
|
||||
config SAMBA4_SERVER_NETBIOS
|
||||
bool "NetBIOS support"
|
||||
depends on PACKAGE_samba4-server
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=samba
|
||||
PKG_VERSION:=4.14.5
|
||||
PKG_VERSION:=4.14.7
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
|
|||
http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
|
||||
http://samba.mirror.bit.nl/samba/ftp/stable/ \
|
||||
https://download.samba.org/pub/samba/stable/
|
||||
PKG_HASH:=bb6ef5d2f16b85288d823578abc453d9a80514c42e5a2ea2c4e3c60dc42335c3
|
||||
PKG_HASH:=6f50353f9602aa20245eb18ceb00e7e5ec793df0974aebd5254c38f16d8f1906
|
||||
|
||||
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-only
|
||||
|
@ -85,7 +85,6 @@ define Package/samba4-server/description
|
|||
endef
|
||||
|
||||
define Package/samba4-server/config
|
||||
select PACKAGE_wsdd2
|
||||
source "$(SOURCE)/Config.in"
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=98
|
||||
STOP=05
|
||||
USE_PROCD=1
|
||||
|
||||
SAMBA_IFACE=""
|
||||
|
@ -25,7 +26,7 @@ smb_header() {
|
|||
)
|
||||
|
||||
# we dont use netbios anymore as default and wsd/avahi is dns based
|
||||
hostname="$(cat /proc/sys/kernel/hostname | tr -d '{};%?=#\n')"
|
||||
hostname="$(sed 's/\..*//' /proc/sys/kernel/hostname | tr -d '{};%?=#\n')"
|
||||
|
||||
config_get_sane workgroup "$1" workgroup "WORKGROUP"
|
||||
config_get_sane description "$1" description "Samba on OpenWrt"
|
||||
|
|
|
@ -29,7 +29,7 @@
|
|||
|
||||
conf.CHECK_CODE('''
|
||||
struct ucred cred;
|
||||
@@ -807,9 +798,6 @@ def configure(conf):
|
||||
@@ -817,9 +808,6 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
|
||||
|
||||
# look for a method of finding the list of network interfaces
|
||||
for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
|
||||
|
@ -39,7 +39,7 @@
|
|||
if conf.CHECK_CODE('''
|
||||
#define %s 1
|
||||
#define NO_CONFIG_H 1
|
||||
@@ -822,7 +810,7 @@ def configure(conf):
|
||||
@@ -832,7 +820,7 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
|
||||
#include "tests/getifaddrs.c"
|
||||
''' % method,
|
||||
method,
|
||||
|
@ -48,7 +48,7 @@
|
|||
addmain=False,
|
||||
execute=True):
|
||||
break
|
||||
@@ -870,7 +858,6 @@ def build(bld):
|
||||
@@ -880,7 +868,6 @@ def build(bld):
|
||||
break
|
||||
|
||||
extra_libs = ''
|
||||
|
|
Loading…
Reference in a new issue