bind: update to version 9.11.19
Fixes: CVE-2020-8616 CVE-2020-8617 Remove backported patch Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
This commit is contained in:
parent
24d14e8b35
commit
58b4399a5c
2 changed files with 2 additions and 29 deletions
|
@ -9,7 +9,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bind
|
PKG_NAME:=bind
|
||||||
PKG_VERSION:=9.11.14
|
PKG_VERSION:=9.11.19
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
USERID:=bind=57:bind=57
|
USERID:=bind=57:bind=57
|
||||||
|
|
||||||
|
@ -21,7 +21,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||||
https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||||
PKG_HASH:=d93b30425996b074a5f9659323b6feae3408e0d325f029f114dfff96ea5e63df
|
PKG_HASH:=0dee554a4caa368948b32da9a0c97b516c19103bc13ff5b3762c5d8552f52329
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
|
PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
|
||||||
|
|
|
@ -1,27 +0,0 @@
|
||||||
From 261c84d91d1b4581df9f7f0ec031908299de7726 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark Andrews <marka@isc.org>
|
|
||||||
Date: Thu, 19 Dec 2019 09:27:44 +1100
|
|
||||||
Subject: [PATCH] fix variable name in conditional block
|
|
||||||
|
|
||||||
Origin: upstream, https://gitlab.isc.org/isc-projects/bind9/commit/261c84d91d1b4581df9f7f0ec031908299de7726
|
|
||||||
|
|
||||||
---
|
|
||||||
lib/isc/stats.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/isc/stats.c b/lib/isc/stats.c
|
|
||||||
index 5bce3c1100..a7ab97ce53 100644
|
|
||||||
--- a/lib/isc/stats.c
|
|
||||||
+++ b/lib/isc/stats.c
|
|
||||||
@@ -297,7 +297,7 @@ setcounter(isc_stats_t *stats,
|
|
||||||
isc_atomic_store((int32_t *)&stats->counters[counter].lo,
|
|
||||||
(uint32_t)(value & 0xffffffff));
|
|
||||||
# else
|
|
||||||
- stats->counters[counter] = val;
|
|
||||||
+ stats->counters[counter] = value;
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.22.2
|
|
||||||
|
|
Loading…
Reference in a new issue