Merge pull request #16288 from Linaro1985/openwrt-21.02_fix_libxslt

[21.02] libxslt: fix compilation because of wrong libxml2 check in configure script
This commit is contained in:
Rosen Penev 2021-08-07 16:57:31 -07:00 committed by GitHub
commit 589625789d
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23

View file

@ -0,0 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
@@ -546,7 +546,7 @@ dnl make sure xml2-config is executable,
dnl test version and init our variables
dnl
-if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs print > /dev/null 2>&1
+if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs > /dev/null 2>&1
then
AC_MSG_CHECKING(for libxml libraries >= $LIBXML_REQUIRED_VERSION)
XMLVERS=`$XML_CONFIG --version`