Merge pull request #16004 from commodo/python-dateutil-setuptools-scm
[19.07] python-dateutil: pin setuptools-scm version to 5.0.2
This commit is contained in:
commit
5837c5a00a
2 changed files with 3 additions and 33 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=python-dateutil
|
||||
PKG_VERSION:=2.8.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -18,6 +18,8 @@ PKG_HASH:=c89805f6f4d64db21ed966fda138f8a5ed7a4fdbc1a8ee329ce1b74e3c74da9e
|
|||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-dateutil-$(PKG_VERSION)
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
|
||||
HOST_PYTHON_PACKAGE_BUILD_DEPENDS:="setuptools-scm==5.0.2"
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
include ../python-package.mk
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -2,8 +2,7 @@
|
||||
requires = [
|
||||
"setuptools; python_version != '3.3'",
|
||||
"setuptools<40.0; python_version == '3.3'",
|
||||
- "wheel",
|
||||
- "setuptools_scm"
|
||||
+ "wheel"
|
||||
]
|
||||
build-backend = "setuptools.build_meta"
|
||||
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -49,9 +49,6 @@ README = README() # NOQA
|
||||
|
||||
|
||||
setup(name="python-dateutil",
|
||||
- use_scm_version={
|
||||
- 'write_to': 'dateutil/_version.py',
|
||||
- },
|
||||
description="Extensions to the standard Python datetime module",
|
||||
author="Gustavo Niemeyer",
|
||||
author_email="gustavo@niemeyer.net",
|
||||
@@ -65,7 +62,6 @@ setup(name="python-dateutil",
|
||||
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*",
|
||||
package_data={"dateutil.zoneinfo": ["dateutil-zoneinfo.tar.gz"]},
|
||||
zip_safe=True,
|
||||
- setup_requires=['setuptools_scm'],
|
||||
install_requires=["six >=1.5"],
|
||||
classifiers=[
|
||||
'Development Status :: 5 - Production/Stable',
|
Loading…
Reference in a new issue